xkeyboard-config: make available outside of X.org, reduce dependencies
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 Apr 2013 10:26:02 +0000 (10:26 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 29 Apr 2013 21:00:56 +0000 (23:00 +0200)
xkeyboard-connfig was selectable only if X.org was enabled. However,
weston, the reference implementation of the Wayland protocol, also
needs xkeyboard-config, so we have to make this package available
outside of the if BR2_PACKAGE_XORG7 ... endif conditional.

In addition to this, the xkeyboard-config currently pulls in
xapp_xkbcomp as a runtime dependency, but this dependency is only
needed with X.org. And it also pulls in xlib_libX11 and xproto_proto
as build-time dependencies. But in fact those ones are runtime
dependencies, and they are only needed under X.org. This helps
reducing the number of dependencies of xkeyboard-config in a
weston/wayland configuration.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/x11r7/Config.in
package/x11r7/xkeyboard-config/Config.in
package/x11r7/xkeyboard-config/xkeyboard-config.mk

index bdc1de167ad8ddf09da2d6bb15e9e6052f784a06..f39ecf6a83b12f6dca2c8adb028437fb342ba50a 100644 (file)
@@ -155,6 +155,7 @@ source "package/x11r7/Config.in"
 comment "X libraries and helper libraries"
 source "package/liberation/Config.in"
 source "package/libsexy/Config.in"
+source "package/x11r7/xkeyboard-config/Config.in"
 
 comment "X Window managers"
 source "package/enlightenment/Config.in"
index 971ef377a92b376040398bba49ee755436dfff6c..f7487daab87e2f58715228eb5f4c7e06f88419f1 100644 (file)
@@ -257,7 +257,6 @@ if BR2_PACKAGE_XORG7
                source package/x11r7/xdata_xbitmaps/Config.in
                source package/x11r7/xdata_xcursor-themes/Config.in
                source package/x11r7/xcursor-transparent-theme/Config.in
-               source package/x11r7/xkeyboard-config/Config.in
        endmenu
 endif
 
index 640bb1d539f975ca91ab23c60cf3c9f2f894bcf6..5d1d6a72ed9b529390fbe2395c6ff5739a096474 100644 (file)
@@ -1,8 +1,9 @@
 config BR2_PACKAGE_XKEYBOARD_CONFIG
        bool "xkeyboard-config"
-       select BR2_PACKAGE_XAPP_XKBCOMP
-       select BR2_PACKAGE_XLIB_LIBX11
-       select BR2_PACKAGE_XPROTO_XPROTO
+       # Runtime dependencies
+       select BR2_PACKAGE_XAPP_XKBCOMP if BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_XLIB_LIBX11 if BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_XPROTO_XPROTO if BR2_PACKAGE_XORG7
        help
          keyboard configuration database for X
 
index 78ed1ee5dc0b29fe1fbc2ab4afb5504fe36badc1..cdddd9569679f59d47859e9a9e6f83eea337711d 100644 (file)
@@ -3,10 +3,15 @@
 # xkeyboard-config
 #
 #############################################################
+
 XKEYBOARD_CONFIG_VERSION = 2.6
 XKEYBOARD_CONFIG_SOURCE = xkeyboard-config-$(XKEYBOARD_CONFIG_VERSION).tar.bz2
 XKEYBOARD_CONFIG_SITE = http://www.x.org/releases/individual/data/xkeyboard-config/
-XKEYBOARD_CONFIG_DEPENDENCIES = host-gettext host-intltool host-xapp_xkbcomp xlib_libX11 xproto_xproto
+XKEYBOARD_CONFIG_LICENSE = MIT
+XKEYBAORD_CONFIG_LICENSE_FILES = COPYING
+
+XKEYBOARD_CONFIG_DEPENDENCIES = host-gettext host-intltool host-xapp_xkbcomp
+XKEYBOARD_CONFIG_CONF_OPT += --disable-runtime-deps
 
 $(eval $(autotools-package))