uhttpd: new package
authorRahul Jain <Rahul.Jain@imgtec.com>
Mon, 17 Oct 2016 11:02:24 +0000 (16:32 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 5 Nov 2016 13:16:29 +0000 (14:16 +0100)
Signed-off-by: Rahul Bedarkar <Rahul.Bedarkar@imgtec.com>
Signed-off-by: Neha Bairathi <Neha.Bairathi@imgtec.com>
Signed-off-by: Abhishek Singh <Abhishek.Singh@imgtec.com>
Signed-off-by: Rahul Jain <Rahul.Jain@imgtec.com>
[Thomas: remove luajit support, as it doesn't build.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/uhttpd/Config.in [new file with mode: 0644]
package/uhttpd/uhttpd.hash [new file with mode: 0644]
package/uhttpd/uhttpd.mk [new file with mode: 0644]

index a24110e8ac9d10a4e618d26633eabb7ee13d9f8f..0d449dcfb7e2e969655f10948093ae8ef0204c24 100644 (file)
@@ -1616,6 +1616,7 @@ endif
        source "package/tunctl/Config.in"
        source "package/tvheadend/Config.in"
        source "package/udpcast/Config.in"
+       source "package/uhttpd/Config.in"
        source "package/ulogd/Config.in"
        source "package/ushare/Config.in"
        source "package/ussp-push/Config.in"
diff --git a/package/uhttpd/Config.in b/package/uhttpd/Config.in
new file mode 100644 (file)
index 0000000..e463b93
--- /dev/null
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_UHTTPD
+       bool "uhttpd"
+       depends on !BR2_STATIC_LIBS # dlopen()
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4 # json-c
+       depends on BR2_USE_MMU # fork()
+       select BR2_PACKAGE_LIBUBOX
+       select BR2_PACKAGE_JSON_C
+       help
+         uHTTPd is a tiny single threaded HTTP server with TLS, CGI and Lua
+         support. It is intended as a drop-in replacement for the Busybox
+         HTTP daemon.
+
+         https://wiki.openwrt.org/doc/howto/http.uhttpd
+
+comment "uhttpd needs a toolchain w/ dynamic library"
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
+       depends on BR2_USE_MMU
+       depends on BR2_STATIC_LIBS
diff --git a/package/uhttpd/uhttpd.hash b/package/uhttpd/uhttpd.hash
new file mode 100644 (file)
index 0000000..59e54ad
--- /dev/null
@@ -0,0 +1,2 @@
+# No hash for this git snapshot
+none   xxx     uhttpd-59e0c739634f46a164d939e54416287b91ff8a9b.tar.gz
diff --git a/package/uhttpd/uhttpd.mk b/package/uhttpd/uhttpd.mk
new file mode 100644 (file)
index 0000000..be0d7d6
--- /dev/null
@@ -0,0 +1,35 @@
+################################################################################
+#
+# uhttpd
+#
+################################################################################
+
+UHTTPD_VERSION = 59e0c739634f46a164d939e54416287b91ff8a9b
+UHTTPD_SITE = http://git.openwrt.org/project/uhttpd.git
+UHTTPD_SITE_METHOD = git
+UHTTPD_LICENSE = ISC
+UHTTPD_LICENSE_FILES = uhttpd.h
+UHTTPD_DEPENDENCIES = libubox json-c
+
+ifeq ($(BR2_PACKAGE_LUA_5_1),y)
+UHTTPD_DEPENDENCIES += lua
+UHTTPD_CONF_OPTS += -DLUA_SUPPORT=ON
+else
+UHTTPD_CONF_OPTS += -DLUA_SUPPORT=OFF
+endif
+
+ifeq ($(BR2_PACKAGE_USTREAM_SSL),y)
+UHTTPD_DEPENDENCIES += ustream-ssl
+UHTTPD_CONF_OPTS += -DTLS_SUPPORT=ON
+else
+UHTTPD_CONF_OPTS += -DTLS_SUPPORT=OFF
+endif
+
+ifeq ($(BR2_PACKAGE_UBUS),y)
+UHTTPD_DEPENDENCIES += ubus
+UHTTPD_CONF_OPTS += -DUBUS_SUPPORT=ON
+else
+UHTTPD_CONF_OPTS += -DUBUS_SUPPORT=OFF
+endif
+
+$(eval $(cmake-package))