Revert "gettext: build libintl unconditionally for uClibc/musl"
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:25:59 +0000 (01:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:25:59 +0000 (01:25 +0200)
This reverts commit 431d00abc1ffd0db287f0392e45229a53db7a187, which in
fact doesn't work for static linking situations, as can be seen in:

  http://autobuild.buildroot.net/results/a6a4039f23a6fbd2bdb5938bcef097a7310452cc/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gettext/Config.in
package/gettext/gettext.mk

index bf16c34d3e13f773ff2234fe77ed542b0628502a..0dea03d18d7a082c2f4d2fa2595a82e1a6068270 100644 (file)
@@ -17,7 +17,7 @@ if BR2_PACKAGE_GETTEXT
 config BR2_PACKAGE_GETTEXT_PROVIDES_LIBINTL
        bool
        depends on !BR2_TOOLCHAIN_HAS_FULL_GETTEXT
-       default y
+       default y if BR2_SYSTEM_ENABLE_NLS
 
 endif
 
index f3325dc6c138f93aed041496420433d3bab3ef74..454ad298a936463cf7eabc2cecb7e29695767388 100644 (file)
@@ -42,7 +42,7 @@ HOST_GETTEXT_CONF_OPTS = \
 # Force the build of libintl, even if the C library provides a stub
 # gettext implementation
 ifeq ($(BR2_PACKAGE_GETTEXT_PROVIDES_LIBINTL),y)
-GETTEXT_CONF_OPTS += --with-included-gettext --enable-nls
+GETTEXT_CONF_OPTS += --with-included-gettext
 else
 GETTEXT_CONF_OPTS += --without-included-gettext
 endif