core/legal-info: install source archives in their own sub-dir
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 7 May 2016 16:14:29 +0000 (18:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 11 May 2016 21:39:37 +0000 (23:39 +0200)
Currently, we put all source archives side-by-side in the same
directory.

Since we're about to also save individual patches that were applied
on those sources, we don't want to make that directory a complete
mess of unassorted files.

So, we install each source archive in its own sub-directory, where
we'll later store the patches too. Store that location in a variable,
so it can be re-used later on (to install patches in a future commit).

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Luca Ceresoli <luca@lucaceresoli.net>
Acked-by: Luca Ceresoli <luca@lucaceresoli.net>
Tested-by: Luca Ceresoli <luca@lucaceresoli.net>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk

index 688123ce0323b936747c0c4d0bf4ca9a874e3cb2..b03187956e2d22d960d4c9d8df029d93ea7a9232 100644 (file)
@@ -482,6 +482,8 @@ endif
 
 $(2)_REDISTRIBUTE              ?= YES
 
+$(2)_REDIST_SOURCES_DIR = $$(REDIST_SOURCES_DIR_$$(call UPPERCASE,$(4)))/$$($(2)_RAW_BASE_NAME)
+
 # When a target package is a toolchain dependency set this variable to
 # 'NO' so the 'toolchain' dependency is not added to prevent a circular
 # dependency
@@ -807,7 +809,7 @@ endif
 # Save the source tarball
        $$(Q)support/scripts/hardlink-or-copy \
                $$(DL_DIR)/$$($(2)_ACTUAL_SOURCE_TARBALL) \
-               $$(REDIST_SOURCES_DIR_$$(call UPPERCASE,$(4)))
+               $$($(2)_REDIST_SOURCES_DIR)
 endif # redistribute
 
 endif # other packages