bluez5_utils: add ability to build sixaxis plugin
authorEric Limpens <limpens@gmail.com>
Thu, 16 Jul 2015 08:46:14 +0000 (10:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 18 Jul 2015 20:53:37 +0000 (22:53 +0200)
[Thomas: add missing udev dependency.]

Signed-off-by: Eric Limpens <limpens@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bluez5_utils/Config.in
package/bluez5_utils/bluez5_utils.mk

index 472432b923c57ab7c491ea1406d8f40ba241e5a7..80c383030be4c9683df47a7bcb07e159c5e96a05 100644 (file)
@@ -58,6 +58,15 @@ config BR2_PACKAGE_BLUEZ5_UTILS_EXPERIMENTAL
        help
          Build BlueZ 5.x experimental plugins (SAP, NFC, ...).
 
+config BR2_PACKAGE_BLUEZ5_PLUGINS_SIXAXIS
+       bool "build sixaxis plugin"
+       depends on BR2_PACKAGE_HAS_UDEV
+       help
+         Build BlueZ 5.x sixaxis plugin (support Sony Dualshock controller)
+
+comment "sixaxis plugin needs udev /dev management"
+       depends on !BR2_PACKAGE_HAS_UDEV
+
 config BR2_PACKAGE_BLUEZ5_UTILS_TEST
        bool "build tests"
        help
index a1adbe1432349df36b1d8e835a7ee1939f0d6a8a..4c50e535b46caba53d86a506d92a82eaef189d58 100644 (file)
@@ -41,6 +41,13 @@ else
 BLUEZ5_UTILS_CONF_OPTS += --disable-experimental
 endif
 
+# enable sixaxis plugin
+ifeq ($(BR2_PACKAGE_BLUEZ5_PLUGINS_SIXAXIS),y)
+BLUEZ5_UTILS_CONF_OPTS += --enable-sixaxis
+else
+BLUEZ5_UTILS_CONF_OPTS += --disable-sixaxis
+endif
+
 # install gatttool (For some reason upstream choose not to do it by default)
 ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS_GATTTOOL),y)
 define BLUEZ5_UTILS_INSTALL_GATTTOOL