package/libcurl: bump version to 7.69.1
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 20 Mar 2020 06:44:51 +0000 (07:44 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 20 Mar 2020 18:44:33 +0000 (19:44 +0100)
Changelog: https://curl.haxx.se/changes.html

Removed polarssl configure options, upstream removed polarssl support:
https://curl.haxx.se/bug/?i=4825

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libcurl/libcurl.hash
package/libcurl/libcurl.mk

index e60194254e2378586a6f288255ca61a62b774b27..69cf7b539865a21e584477774b01bc1d992c7d66 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 b724240722276a27f6e770b952121a3afd097129d8c9fe18e6272dc34192035a  curl-7.68.0.tar.xz
+sha256 03c7d5e6697f7b7e40ada1b2256e565a555657398e6c1fcfa4cb251ccd819d4f  curl-7.69.1.tar.xz
 sha256 db3c4a3b3695a0f317a0c5176acd2f656d18abc45b3ee78e50935a78eb1e132e  COPYING
index 5de2591178056ea77cc3a228bfee8ed9f2a2d839..7a29634c68872cc2b4dcebac4db5330d526aee3f 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBCURL_VERSION = 7.68.0
+LIBCURL_VERSION = 7.69.1
 LIBCURL_SOURCE = curl-$(LIBCURL_VERSION).tar.xz
 LIBCURL_SITE = https://curl.haxx.se/download
 LIBCURL_DEPENDENCIES = host-pkgconf \
@@ -22,7 +22,7 @@ LIBCURL_INSTALL_STAGING = YES
 # generate C code) isn't very useful
 LIBCURL_CONF_OPTS = --disable-manual --disable-ntlm-wb \
        --enable-hidden-symbols --with-random=/dev/urandom --disable-curldebug \
-       --without-polarssl --disable-libcurl-option
+       --disable-libcurl-option
 
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
 LIBCURL_CONF_OPTS += --enable-threaded-resolver
@@ -184,7 +184,6 @@ HOST_LIBCURL_CONF_OPTS = \
        --with-ssl \
        --without-gnutls \
        --without-mbedtls \
-       --without-polarssl \
        --without-nss
 
 HOST_LIBCURL_POST_PATCH_HOOKS += LIBCURL_FIX_DOT_PC