package/wireguard-linux-compat: new package
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 9 Jan 2020 09:16:19 +0000 (10:16 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 9 Jan 2020 16:56:39 +0000 (17:56 +0100)
With the kernel support for WireGuard getting mainlined, the upstream repo
has been split in a wireguard-tools repo for the userspace tooling and
wireguard-linux-compat for the kernel side (for 3.10+ legacy kernels).

Add a wireguard-linux-compat for the compatibility out-of-tree kernel
module, and update the Config.in.legacy handling to use it.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Config.in.legacy
DEVELOPERS
package/Config.in
package/wireguard-linux-compat/Config.in [new file with mode: 0644]
package/wireguard-linux-compat/wireguard-linux-compat.hash [new file with mode: 0644]
package/wireguard-linux-compat/wireguard-linux-compat.mk [new file with mode: 0644]

index b9bb1aa57d1e721ba9adce18aee444fe4be5f534..1801ec06da5c9124499e1b297f5fc65c866ceb9f 100644 (file)
@@ -150,10 +150,12 @@ config BR2_PACKAGE_WIREGUARD
        bool "wireguard package renamed"
        depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_10
        select BR2_LEGACY
+       select BR2_PACKAGE_WIREGUARD_LINUX_COMPAT if BR2_LINUX_KERNEL
        select BR2_PACKAGE_WIREGUARD_TOOLS
        help
-         The wireguard package has been renamed to wireguard-tools to
-         match upstream.
+         The wireguard package has been renamed to wireguard-tools
+         for the userspace tooling and wireguard-linux-compat for the
+         kernel side for legacy (<5.6) kernels to match upstream.
 
 config BR2_PACKAGE_PERL_NET_PING
        bool "perl-net-ping was removed"
index 66dc7cf4c281042a186a4bb2bccae1e9a0b50adf..80843dd1a113ec85699fd7e17e3529d984e1cd80 100644 (file)
@@ -1945,6 +1945,7 @@ F:        package/python-websocket-client/
 F:     package/sedutil/
 F:     package/tpm2-totp/
 F:     package/triggerhappy/
+F:     package/wireguard-linux-compat/
 F:     package/wireguard-tools/
 F:     support/testing/tests/package/test_docker_compose.py
 
index 170a1c986d0fab66eaff11c06b9274d81d00762f..873a592d64d1695b85a3370e8cf265c252fc461f 100644 (file)
@@ -2176,6 +2176,7 @@ endif
        source "package/wavemon/Config.in"
        source "package/wget/Config.in"
        source "package/whois/Config.in"
+       source "package/wireguard-linux-compat/Config.in"
        source "package/wireguard-tools/Config.in"
        source "package/wireless-regdb/Config.in"
        source "package/wireless_tools/Config.in"
diff --git a/package/wireguard-linux-compat/Config.in b/package/wireguard-linux-compat/Config.in
new file mode 100644 (file)
index 0000000..4ee214b
--- /dev/null
@@ -0,0 +1,23 @@
+config BR2_PACKAGE_WIREGUARD_LINUX_COMPAT
+       bool "wireguard linux-compat"
+       depends on BR2_LINUX_KERNEL
+       # kernel module requires 3.10+
+       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_10
+       help
+         WireGuard is an extremely simple yet fast and modern VPN
+         that utilizes state-of-the-art cryptography. It aims to be
+         faster, simpler, leaner, and more useful than IPSec, while
+         avoiding the massive headache. It intends to be considerably
+         more performant than OpenVPN. WireGuard is designed as a
+         general purpose VPN for running on embedded interfaces and
+         super computers alike, fit for many different
+         circumstances.
+
+         Support for WireGuard is included in Linux 5.6+. This
+         package provides a backport of the kernel support for older
+         kernels.
+
+         https://www.wireguard.com
+
+comment "wireguard-linux-compat needs a toolchain w/ headers >= 3.10"
+       depends on BR2_LINUX_KERNEL && !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_10
diff --git a/package/wireguard-linux-compat/wireguard-linux-compat.hash b/package/wireguard-linux-compat/wireguard-linux-compat.hash
new file mode 100644 (file)
index 0000000..1653eaa
--- /dev/null
@@ -0,0 +1,4 @@
+# https://lists.zx2c4.com/pipermail/wireguard/2020-January/004844.html
+sha256 9f12f68e96f6865325995c38213e09b05751cd1ef03e0bbc9f1bdc3e5680b337  wireguard-linux-compat-0.0.20200105.tar.xz
+# Locally calculated
+sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
diff --git a/package/wireguard-linux-compat/wireguard-linux-compat.mk b/package/wireguard-linux-compat/wireguard-linux-compat.mk
new file mode 100644 (file)
index 0000000..ddceed5
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# wireguard
+#
+################################################################################
+
+WIREGUARD_LINUX_COMPAT_VERSION = 0.0.20200105
+WIREGUARD_LINUX_COMPAT_SITE = https://git.zx2c4.com/wireguard-linux-compat/snapshot
+WIREGUARD_LINUX_COMPAT_SOURCE = wireguard-linux-compat-$(WIREGUARD_LINUX_COMPAT_VERSION).tar.xz
+WIREGUARD_LINUX_COMPAT_LICENSE = GPL-2.0
+WIREGUARD_LINUX_COMPAT_LICENSE_FILES = COPYING
+WIREGUARD_LINUX_COMPAT_MODULE_SUBDIRS = src
+
+$(eval $(kernel-module))
+$(eval $(generic-package))