package/minidlna: fix static build
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 18 Nov 2015 23:31:06 +0000 (00:31 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 19 Nov 2015 09:49:34 +0000 (10:49 +0100)
libvorbis.pc does not exist, it is named vorbis.pc.
Also, sqlite3 was missing when querying pkg-config.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/minidlna/minidlna.mk

index e9df92b20e4a5e01ddc4e99f0f8e70348c6d9f4e..e00fa09fb7bd49998c12ddf47f3cb96bdaa90aa1 100644 (file)
@@ -17,7 +17,8 @@ MINIDLNA_DEPENDENCIES = \
 ifeq ($(BR2_STATIC_LIBS),y)
 # the configure script / Makefile forgets to link with some of the dependent
 # libraries breaking static linking, so help it along
-MINIDLNA_STATIC_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs libavcodec libexif libvorbis`
+MINIDLNA_PKGCONFIG_DEPS = libavcodec libexif vorbis sqlite3
+MINIDLNA_STATIC_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs $(MINIDLNA_PKGCONFIG_DEPS)`
 MINIDLNA_STATIC_LIBS += $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),-lintl)
 MINIDLNA_CONF_ENV += LIBS="$(MINIDLNA_STATIC_LIBS)"
 else