- revert incorrect parts from sjhill's r17800 and add some more documentation.
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 12 Feb 2007 17:42:18 +0000 (17:42 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 12 Feb 2007 17:42:18 +0000 (17:42 -0000)
  Now the kernel as well as /lib/modules are properly included in the final tarball and all other tarroot/genfs targets.

target/Makefile.in
target/device/Makefile.in

index 7ec139db988c46602bab295d2089f4b2e0d847a2..d00442d10a364c5878daf6059e2a0ec8e27a97a9 100644 (file)
@@ -1,13 +1,15 @@
 # make sure to put everything that is board-specific before the tarroot targets
 include target/generic/Makefile.in
+
+# this eventually adds the kernel target to TARGETS:
 include target/device/Makefile.in
 include target/x86/Makefile.in
 include target/arm/Makefile.in
 include target/powerpc/Makefile.in
 # and finally build the filesystems/tarballs
 include target/*/*.mk
+
 # kernel rules
-ifeq ($(BR2_PACKAGE_LINUX),y)
-TARGETS+=linux26
-endif
+# We already did add the kernel target to TARGETS and now just pull in the rules
+# to actually build this target.
 include target/linux*.mk
index c2d04a97a94b1f8ca3397521a709cd66fab4b6b0..be23fc7bb1e9c8fb8e354a1af1386eebe6c5c280 100644 (file)
@@ -1,3 +1,8 @@
 TARGET_DEVICE_DEPMOD:=target/device/x86/depmod.pl
 
 -include target/device/*/Makefile.in
+
+ifeq ($(BR2_PACKAGE_LINUX),y)
+TARGETS+=linux26
+endif
+