imagemagick: bump to version 7.0.2-0
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 15 Jun 2016 12:34:21 +0000 (09:34 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 15 Jun 2016 21:11:44 +0000 (23:11 +0200)
Add new disables for libraries that aren't supported in buildroot and
sort them for ease of maintenance.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/imagemagick/imagemagick.hash
package/imagemagick/imagemagick.mk

index 8a5104714535aa8481bf5878c5939616f8166bc2..e34f15a81d4b4ab2a75f92a7984a328c11909d10 100644 (file)
@@ -1,2 +1,2 @@
 # From http://www.imagemagick.org/download/releases/digest.rdf
-sha256 c028642af5f4cbae864b4afd6ea96878191be64103ca9c7cc67612ec3cbb9dec ImageMagick-6.9.4-6.tar.xz
+sha256 cd3076a573a815ff828c75d231eef8660f2f6c5eaf848c2f4e8c4dcc955671ea        ImageMagick-7.0.2-0.tar.xz
index 74ac5a464c7dead87450da91137fae9a76ed0518..065f33dbaea025e47e187d512634b164be03bfaa 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-IMAGEMAGICK_VERSION = 6.9.4-6
+IMAGEMAGICK_VERSION = 7.0.2-0
 IMAGEMAGICK_SOURCE = ImageMagick-$(IMAGEMAGICK_VERSION).tar.xz
 IMAGEMAGICK_SITE = http://www.imagemagick.org/download/releases
 IMAGEMAGICK_LICENSE = Apache-2.0
@@ -12,7 +12,7 @@ IMAGEMAGICK_LICENSE_FILES = LICENSE
 
 IMAGEMAGICK_INSTALL_STAGING = YES
 IMAGEMAGICK_CONFIG_SCRIPTS = \
-       $(addsuffix -config,Magick MagickCore MagickWand Wand)
+       $(addsuffix -config,MagickCore MagickWand)
 
 ifeq ($(BR2_INSTALL_LIBSTDCPP)$(BR2_USE_WCHAR),yy)
 IMAGEMAGICK_CONFIG_SCRIPTS += Magick++-config
@@ -23,16 +23,19 @@ IMAGEMAGICK_CONF_ENV = ac_cv_sys_file_offset_bits=64
 IMAGEMAGICK_CONF_OPTS = \
        --program-transform-name='s,,,' \
        --disable-openmp \
-       --without-perl \
-       --without-wmf \
-       --without-openexr \
-       --without-jp2 \
-       --without-jbig \
-       --without-gvc \
        --without-djvu \
        --without-dps \
-       --without-gslib \
+       --without-flif \
        --without-fpx \
+       --without-gslib \
+       --without-gvc \
+       --without-jbig \
+       --without-jp2 \
+       --without-lqr \
+       --without-openexr \
+       --without-perl \
+       --without-raqm \
+       --without-wmf \
        --without-x
 
 IMAGEMAGICK_DEPENDENCIES = host-pkgconf