opkg: gpg support needs libgpg-error
authorPeter Korsgaard <peter@korsgaard.com>
Sat, 6 Jun 2015 13:38:56 +0000 (15:38 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 6 Jun 2015 13:38:56 +0000 (15:38 +0200)
Fixes:
http://autobuild.buildroot.net/results/1ec/1ec6990354016a740a8f54e07066e5fa4e732ab0/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/opkg/Config.in
package/opkg/opkg.mk

index df6ebff2a9912e8ecbd4f224bf3a5c3be59832e2..495ce91f3ee7be89b5d19931e45bbabd3cf7d3ad 100644 (file)
@@ -23,6 +23,7 @@ if BR2_PACKAGE_OPKG
 config BR2_PACKAGE_OPKG_GPG_SIGN
        bool "gnupg support"
        select BR2_PACKAGE_LIBGPGME
+       select BR2_PACKAGE_LIBGPG_ERROR
        help
          Enable opkg package signature checking support using
          gnupg/libgpgme.
index 5c79fc7e5da4da90190a70222d983ec2782a0939..bcf3f78057797163050bc5a44e014ac8627bfe43 100644 (file)
@@ -22,8 +22,10 @@ endef
 
 ifeq ($(BR2_PACKAGE_OPKG_GPG_SIGN),y)
 OPKG_CONF_OPTS += --enable-gpg
-OPKG_CONF_ENV = ac_cv_path_GPGME_CONFIG=$(STAGING_DIR)/usr/bin/gpgme-config
-OPKG_DEPENDENCIES += libgpgme
+OPKG_CONF_ENV += \
+       ac_cv_path_GPGME_CONFIG=$(STAGING_DIR)/usr/bin/gpgme-config \
+       ac_cv_path_GPGERR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config
+OPKG_DEPENDENCIES += libgpgme libgpg-error
 else
 OPKG_CONF_OPTS += --disable-gpg
 endif