toolchain/gcc: do not try to strip *-embedspu
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 4 Apr 2008 14:16:06 +0000 (14:16 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 4 Apr 2008 14:16:06 +0000 (14:16 -0000)
toolchain/gcc/gcc-uclibc-3.x.mk
toolchain/gcc/gcc-uclibc-4.x.mk

index 1e003f2e316e9b0bfeb4edba9287d4c8f4e5b327..58afa926144cf6e8817c7557553bb264f6b735ee 100644 (file)
@@ -286,7 +286,7 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
        fi
        # Strip the host binaries
 ifeq ($(GCC_STRIP_HOST_BINARIES),true)
-       strip --strip-all -R .note -R .comment $(filter-out %-gccbug,$(wildcard $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*))
+       strip --strip-all -R .note -R .comment $(filter-out %-gccbug %-embedspu,$(wildcard $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*))
 endif
        # Make sure we have 'cc'.
        if [ ! -e $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc ]; then \
index c6ecabadde89754e57d7823cc067aef3dd9a9b73..5365cdff1459fcfb1a3abed8d796f806c4d19504 100644 (file)
@@ -299,7 +299,7 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
        fi
        # Strip the host binaries
 ifeq ($(GCC_STRIP_HOST_BINARIES),true)
-       strip --strip-all -R .note -R .comment $(filter-out %-gccbug,$(wildcard $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*))
+       strip --strip-all -R .note -R .comment $(filter-out %-gccbug %-embedspu,$(wildcard $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*))
 endif
        # Make sure we have 'cc'.
        if [ ! -e $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc ]; then \