package/x11r7/xserver_xorg-server: add --enable-libdrm for udev
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 31 Mar 2015 15:50:30 +0000 (12:50 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 31 Mar 2015 21:41:26 +0000 (23:41 +0200)
If the libdrm package is enabled, the system is built with an udev
provider and MESA3D_DRI_DRIVER is disabled this adds a --disable-libdrm
to configure options, but udev still requires libdrm and results in a
build failure since libdrm include paths aren't filled in (missing drm.h
include error).
So add --enable-libdrm for the udev scenario to counteract the previous
--disable-libdrm.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index bb5381c1c603124c118ecbf2024803b34a8e1b27..d9f36fc5c0ada9d64c5ff1b7b5ec1d4b6769caa5 100644 (file)
@@ -130,7 +130,7 @@ XSERVER_XORG_SERVER_CONF_OPTS += --enable-config-udev
 # udev kms support depends on libdrm
 ifeq ($(BR2_PACKAGE_LIBDRM),y)
 XSERVER_XORG_SERVER_DEPENDENCIES += libdrm
-XSERVER_XORG_SERVER_CONF_OPTS += --enable-config-udev-kms
+XSERVER_XORG_SERVER_CONF_OPTS += --enable-config-udev-kms --enable-libdrm
 else
 XSERVER_XORG_SERVER_CONF_OPTS += --disable-config-udev-kms
 endif