grep: fix build failure for musl
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 7 Nov 2014 12:56:57 +0000 (09:56 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 7 Nov 2014 13:33:07 +0000 (14:33 +0100)
musl doesn't implement re_match and friends and grep fails to
detect this properly, so force internal regex routines for musl.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/grep/grep.mk

index e07f1691885f49765e0a8a5d0564ec7047868dd0..2c2477c882ce46706c6a6a9a797546a1146c53ac 100644 (file)
@@ -9,7 +9,8 @@ GREP_SITE = $(BR2_GNU_MIRROR)/grep
 GREP_SOURCE = grep-$(GREP_VERSION).tar.xz
 GREP_LICENSE = GPLv3+
 GREP_LICENSE_FILES = COPYING
-GREP_CONF_OPTS = --disable-perl-regexp --without-included-regex
+GREP_CONF_OPTS = --disable-perl-regexp \
+       $(if $(BR2_TOOLCHAIN_USES_MUSL),--with-included-regex)
 GREP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
 
 # link with iconv if enabled