package/php: drop BR2_PACKAGE_PHP_EXT_HASH
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 23 Aug 2020 15:02:31 +0000 (17:02 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 23 Aug 2020 17:03:20 +0000 (19:03 +0200)
hash extension can't be disabled since version 7.4.0 and
https://github.com/php/php-src/commit/bf344425812b0f6156d0a8a54ed7bc38054f7636

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Config.in.legacy
package/php/Config.ext
package/php/php.mk

index cf7aaf75a5ba82afe9d4df4e15ae8b06a66aa1ad..957cbb8b3c6235f2f53a5fcfdb3211731bf63fab 100644 (file)
@@ -146,6 +146,12 @@ endif
 
 comment "Legacy options removed in 2020.08"
 
+config BR2_PACKAGE_PHP_EXT_HASH
+       bool "php hash extension is mandatory"
+       select BR2_LEGACY
+       help
+         Since php 7.4.0, hash extension can't be disabled.
+
 config BR2_PACKAGE_EFL_GIF
        bool "efl evas gif loader is mandatory"
        select BR2_LEGACY
index 556276da97b503f5bdc3c59134c3c297ecb6ce22..44afea010b6d69428ec65d9b4e265bc21db5e2a3 100644 (file)
@@ -65,11 +65,6 @@ config BR2_PACKAGE_PHP_EXT_ZLIB
 
 comment "Cryptography extensions"
 
-config BR2_PACKAGE_PHP_EXT_HASH
-       bool "hash"
-       help
-         HASH message digest framework
-
 comment "libargon2 needs a toolchain w/ dynamic library"
        depends on BR2_USE_MMU
        depends on BR2_STATIC_LIBS
@@ -136,7 +131,6 @@ endif
 
 config BR2_PACKAGE_PHP_EXT_MYSQLI
        bool "Mysqli"
-       select BR2_PACKAGE_PHP_EXT_HASH
        help
          MySQL Improved extension support
 
@@ -168,7 +162,6 @@ if BR2_PACKAGE_PHP_EXT_PDO
 
 config BR2_PACKAGE_PHP_EXT_PDO_MYSQL
        bool "MySQL"
-       select BR2_PACKAGE_PHP_EXT_HASH
        help
          PDO driver for MySQL
 
index ef9c7e86446446ec49ab5482d6207b8e748f9385..d9516ae1270e6f9ae7ed2f2d9af5387bc04af322 100644 (file)
@@ -97,7 +97,6 @@ PHP_CONF_OPTS += \
        $(if $(BR2_PACKAGE_PHP_EXT_SOCKETS),--enable-sockets) \
        $(if $(BR2_PACKAGE_PHP_EXT_POSIX),--enable-posix) \
        $(if $(BR2_PACKAGE_PHP_EXT_SESSION),--enable-session) \
-       $(if $(BR2_PACKAGE_PHP_EXT_HASH),--enable-hash) \
        $(if $(BR2_PACKAGE_PHP_EXT_DOM),--enable-dom) \
        $(if $(BR2_PACKAGE_PHP_EXT_SIMPLEXML),--enable-simplexml) \
        $(if $(BR2_PACKAGE_PHP_EXT_SOAP),--enable-soap) \