use '/bin/echo -e' to make certain we don't use an unusable /bin/sh builtin
authorEric Andersen <andersen@codepoet.org>
Fri, 8 Dec 2006 05:23:08 +0000 (05:23 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 8 Dec 2006 05:23:08 +0000 (05:23 -0000)
package/acpid/acpid.mk
package/config/Makefile

index bd0ed406df9b75b356727ffa85d31cac4b0f060f..31afba8131003caecf7b94d1f1c4cfc9d17e2c8b 100644 (file)
@@ -24,7 +24,7 @@ $(ACPID_DIR)/acpid: $(ACPID_DIR)/.unpacked
 $(TARGET_DIR)/usr/sbin/acpid: $(ACPID_DIR)/acpid
        cp -a $(ACPID_DIR)/acpid $(TARGET_DIR)/usr/sbin/acpid
        mkdir -p $(TARGET_DIR)/etc/acpi/events
-       echo -e "event=button[ /]power\naction=/sbin/poweroff" > $(TARGET_DIR)/etc/acpi/events/powerbtn
+       /bin/echo -e "event=button[ /]power\naction=/sbin/poweroff" > $(TARGET_DIR)/etc/acpi/events/powerbtn
        touch -c $(TARGET_DIR)/usr/sbin/acpid
 
 acpid: $(TARGET_DIR)/usr/sbin/acpid
index e2ca6fdd87e04de8f87e6df66ed4c764935889ea..430138f77f8af6fdcce0b5d27a899ef31a3de7aa 100644 (file)
@@ -116,7 +116,7 @@ ncurses:
                $(RM) lxtemp.c a.out; \
        else \
                $(RM) lxtemp.c; \
-               echo -e "\007" ;\
+               /bin/echo -e "\007" ;\
                echo ">> Unable to find the Ncurses libraries." ;\
                echo ">>" ;\
                echo ">> You must have Ncurses installed in order" ;\