u-boot: add 2010.03, adapt target mkimage step to work with 2010.03
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 2 Apr 2010 13:00:59 +0000 (15:00 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 2 Apr 2010 13:00:59 +0000 (15:00 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
target/u-boot/Config.in
target/u-boot/Makefile.in

index 2689f6975891ae32ec7b86accc4c5093b64e9c87..f84d181e609a293bad080030aff8bcdb999ca076 100644 (file)
@@ -13,12 +13,16 @@ config BR2_TARGET_UBOOT_BOARDNAME
 
 choice
        prompt "U-Boot Version"
-       default BR2_TARGET_UBOOT_2009_11
+       default BR2_TARGET_UBOOT_2010_03
        help
          Select the specific U-Boot version you want to use
 
+config BR2_TARGET_UBOOT_2010_03
+       bool "u-boot-2010.03"
+
 config BR2_TARGET_UBOOT_2009_11
        bool "u-boot-2009.11"
+       depends on BR2_DEPRECATED || BR2_RECENT
 
 config BR2_TARGET_UBOOT_2009_08
        bool "u-boot-2009.08"
@@ -48,6 +52,7 @@ endchoice
 
 config BR2_UBOOT_VERSION
        string
+       default "2010.03"       if BR2_TARGET_UBOOT_2010_03
        default "2009.11"       if BR2_TARGET_UBOOT_2009_11
        default "2009.08"       if BR2_TARGET_UBOOT_2009_08
        default "2009.06"       if BR2_TARGET_UBOOT_2009_06
index 5efbd54d2f5edbabf531dedaaef1ded244ef44d1..d1bb5e531024783a3539a48424671adacfc02851 100644 (file)
@@ -177,7 +177,7 @@ $(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/$(U_BOOT_BIN)
                -DUSE_HOSTCC -o $@ \
                $(U_BOOT_DIR)/common/image.c \
                $(wildcard $(addprefix $(U_BOOT_DIR)/tools/,default_image.c \
-                       fit_image.c kwbimage.c mkimage.c)) \
+                       fit_image.c imximage.c kwbimage.c mkimage.c)) \
                $(addprefix $(U_BOOT_DIR)/lib_generic/,crc32.c md5.c sha1.c) \
                $(U_BOOT_DIR)/tools/os_support.c \
                $(U_BOOT_DIR)/libfdt/fdt*.c