tinyalsa: Fix overwrite of asound.h
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Sat, 18 Oct 2014 13:21:14 +0000 (15:21 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 18 Oct 2014 17:17:07 +0000 (19:17 +0200)
As stated by Maarten ter Huurne on the mailing list, the install of the
asound.h headers overwrite the one from the toolchains or kernel
headers.
Since tinyals's header is only a subset of the 'real' asound.h, there is
no need to overwrite it.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Cc: Maarten ter Huurne <maarten@treewalker.org>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tinyalsa/tinyalsa.mk

index b287e787293dde40b7ddba192f9c43d1ae5b72c1..48288f174ae6db7d1007050046790b5c816a2291 100644 (file)
@@ -16,8 +16,6 @@ endef
 define TINYALSA_INSTALL_STAGING_CMDS
        $(INSTALL) -D -m 0755 $(@D)/libtinyalsa.so \
                        $(STAGING_DIR)/usr/lib/libtinyalsa.so
-       $(INSTALL) -D -m 0644 $(@D)/include/sound/asound.h \
-                       $(STAGING_DIR)/usr/include/sound/asound.h
        $(INSTALL) -D -m 0644 $(@D)/include/tinyalsa/asoundlib.h \
                        $(STAGING_DIR)/usr/include/tinyalsa/asoundlib.h
 endef