docker-containerd: add missing docker-containerd symlink
authorSam Lancia <sam@gpsm.co.uk>
Thu, 7 Jun 2018 07:51:07 +0000 (08:51 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 7 Jun 2018 13:47:53 +0000 (15:47 +0200)
Prior to commit 2dccb4f2fefd8a0dbda65dd0f7537f811e920b13
("package/docker-containerd: convert to golang infrastructure"), the
containerd binary was installed as docker-containerd. Following the
conversion to the golang package infrastructure, the binary is now
installed as "containerd", which breaks some use cases.

Let's add a symlink link docker-containerd -> containerd to fix such
use cases.

Fixes: https://bugs.busybox.net/show_bug.cgi?id=11076
Signed-off-by: Sam Lancia <sam@gpsm.co.uk>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/docker-containerd/docker-containerd.mk

index 88e27b5ed446848100f620ba8e5facaab2fe1af9..09e89f1aba1400d078e44d05686f5cbfa55df311 100644 (file)
@@ -21,6 +21,7 @@ DOCKER_CONTAINERD_INSTALL_BINS = containerd containerd-shim
 define DOCKER_CONTAINERD_INSTALL_SYMLINKS
        ln -fs runc $(TARGET_DIR)/usr/bin/docker-runc
        ln -fs containerd-shim $(TARGET_DIR)/usr/bin/docker-containerd-shim
+       ln -fs containerd $(TARGET_DIR)/usr/bin/docker-containerd
 endef
 
 DOCKER_CONTAINERD_POST_INSTALL_TARGET_HOOKS += DOCKER_CONTAINERD_INSTALL_SYMLINKS