libecore: fix build of host-libecore when X11 not available
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 28 Feb 2012 22:35:48 +0000 (23:35 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 29 Feb 2012 09:00:24 +0000 (10:00 +0100)
The host-libecore build tries to build the X11 backend. This works if
you have X11 headers/libraries installed on your build machine, but
fails if you don't, and Buildroot shouldn't depend on such things
being installed.

Therefore, we force host-libecore to not build any of the graphical
backends (X, XCB or DirectFB).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/efl/libecore/libecore.mk

index db14356ae6614254b84e289b34f4ebbdde4e8737..c76b3ffa2a4a27b24a9a5f707799d6f5c31f3d0a 100644 (file)
@@ -12,7 +12,13 @@ LIBECORE_INSTALL_STAGING = YES
 LIBECORE_DEPENDENCIES = host-pkg-config libeina
 
 HOST_LIBECORE_DEPENDENCIES = host-pkg-config host-libeina host-libevas
-HOST_LIBECORE_CONF_OPT += --enable-ecore-evas
+HOST_LIBECORE_CONF_OPT +=              \
+       --enable-ecore-evas             \
+       --disable-simple-x11            \
+       --disable-ecore-directfb        \
+       --disable-ecore-x               \
+       --disable-ecore-x-xcb           \
+       --disable-ecore-imf-xim
 
 # default options
 LIBECORE_CONF_OPT = --disable-simple-x11