package/go-bootstrap: Add toolchain dependency
authorGeoff Levand <geoff@infradead.org>
Thu, 12 May 2016 00:08:46 +0000 (00:08 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 12 May 2016 14:06:57 +0000 (16:06 +0200)
To build programs that need cgo support the toolchain needs to
be available.

Cc: Christian Stewart <christian@paral.in>
Signed-off-by: Geoff Levand <geoff@infradead.org>
[Thomas: add comment in the code about the toolchain dependency.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/go-bootstrap/go-bootstrap.mk

index e404cb6966a7aacc13fbf93bc3eceea147c761da..fd236289411e75e13573ae8942c3a441f119b70f 100644 (file)
@@ -11,6 +11,12 @@ GO_BOOTSTRAP_SOURCE = go$(GO_BOOTSTRAP_VERSION).src.tar.gz
 GO_BOOTSTRAP_LICENSE = BSD-3c
 GO_BOOTSTRAP_LICENSE_FILES = LICENSE
 
+# To build programs that need cgo support the toolchain needs to be
+# available, so the toolchain is not needed to build host-go-bootstrap
+# itself, but needed by other packages that depend on
+# host-go-bootstrap.
+HOST_GO_BOOTSTRAP_DEPENDENCIES = toolchain
+
 HOST_GO_BOOTSTRAP_ROOT = $(HOST_DIR)/usr/lib/go-$(GO_BOOTSTRAP_VERSION)
 
 HOST_GO_BOOTSTRAP_MAKE_ENV = \