buildroot: add basic Bazaar support
authorSven Neumann <s.neumann@raumfeld.com>
Fri, 7 Aug 2009 09:57:54 +0000 (11:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 7 Sep 2009 21:37:03 +0000 (23:37 +0200)
This change adds the config options BR2_BZR_CO and BR2_BZR_UP that
allow to configure the commands for doing a checkout/update from
a Bazaar repository.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Config.in
project/Makefile.in

index 1881f8253b76669eea46a1c83b33bd612a3740ed..146bb17a88278f5420c9b9ceb3543449d3dbbd27 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -27,6 +27,14 @@ config BR2_SVN_UP
        string "Subversion (svn) command to update source tree"
        default "svn up"
 
+config BR2_BZR_CO
+       string "Bazaar (bzr) command to download source tree"
+       default "bzr co"
+
+config BR2_BZR_UP
+       string "Bazaar (bzr) command to update source tree"
+       default "bzr up"
+
 config BR2_GIT
        string "Git command to download source tree"
        default "git clone"
index 7f359bcf7f3ca628c2498f4a5e4907b92dde9ba8..69c8572e0a390741f4353ec224771071e43f7bc8 100644 (file)
@@ -13,6 +13,8 @@ endif
 WGET:=$(call qstrip,$(BR2_WGET)) $(SPIDER) $(QUIET)
 SVN_CO:=$(call qstrip,$(BR2_SVN_CO)) $(QUIET)
 SVN_UP:=$(call qstrip,$(BR2_SVN_UP)) $(QUIET)
+BZR_CO:=$(call qstrip,$(BR2_BZR_CO)) $(QUIET)
+BZR_UP:=$(call qstrip,$(BR2_BZR_UP)) $(QUIET)
 GIT:=$(call qstrip,$(BR2_GIT)) $(QUIET)
 ZCAT:=$(call qstrip,$(BR2_ZCAT))
 BZCAT:=$(call qstrip,$(BR2_BZCAT))