package/sdl_sound: actually use the optional CONF_OPTS
authorRicardo Martincoski <ricardo.martincoski@gmail.com>
Sun, 27 Jan 2019 18:59:37 +0000 (16:59 -0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 27 Jan 2019 21:15:55 +0000 (22:15 +0100)
Since "57ace26b6c package/sdl_sound: add optional support for
libmodplug" from 2016, optional CONF_OPTS are added but they do not
really take effect because there is an unconditional override below the
conditional append.

Currently this does not cause build failures, but it can lead to wrong
detection of dependencies because many explicit --enable/--disable are
not passed to configure.

Fix this by moving the unconditional code to the top.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sdl_sound/sdl_sound.mk

index 2544b598e939d5764fa4732210a5fa627b02489f..c6028e79106ecc25b44328ae18c7e8991abf98fe 100644 (file)
@@ -11,6 +11,11 @@ SDL_SOUND_LICENSE = LGPL-2.1+
 SDL_SOUND_LICENSE_FILES = COPYING
 SDL_SOUND_INSTALL_STAGING = YES
 SDL_SOUND_DEPENDENCIES = sdl
+SDL_SOUND_CONF_OPTS = \
+       --with-sdl-prefix=$(STAGING_DIR)/usr \
+       --with-sdl-exec-prefix=$(STAGING_DIR)/usr \
+       --disable-sdltest \
+       --enable-static
 
 ifneq ($(BR2_ENABLE_LOCALE),y)
 SDL_SOUND_DEPENDENCIES += libiconv
@@ -52,12 +57,6 @@ else
 SDL_SOUND_CONF_OPTS += --disable-physfs
 endif
 
-SDL_SOUND_CONF_OPTS = \
-       --with-sdl-prefix=$(STAGING_DIR)/usr \
-       --with-sdl-exec-prefix=$(STAGING_DIR)/usr \
-       --disable-sdltest \
-       --enable-static
-
 ifeq ($(BR2_X86_CPU_HAS_MMX),y)
 SDL_SOUND_CONF_OPTS += --enable-mmx
 else