package/mpv: add optional support for OpenGLES
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 18 Jun 2021 19:22:35 +0000 (21:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 18 Jul 2021 21:33:00 +0000 (23:33 +0200)
mpv also supports OpenGLES:
https://github.com/mpv-player/mpv/blob/master/video/out/opengl/egl_helpers.c#L98

Runtime-tested using mesa3d iris driver on a non-x11 system.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpv/mpv.mk

index 30f377054f2969aa66e975ba6068b0c63fed0195..877b84f63ae450d668a20097efad860fcd8655ac 100644 (file)
@@ -140,6 +140,9 @@ endif
 ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
 MPV_CONF_OPTS += --enable-gl
 MPV_DEPENDENCIES += libgl
+else ifeq ($(BR2_PACKAGE_HAS_LIBGLES),y)
+MPV_CONF_OPTS += --enable-gl
+MPV_DEPENDENCIES += libgles
 else
 MPV_CONF_OPTS += --disable-gl
 endif