skeleton: use BR2_SYSTEM_DEFAULT_PATH as default PATH
authorMarkus Mayer <mmayer@broadcom.com>
Thu, 20 Dec 2018 17:58:12 +0000 (09:58 -0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 31 Dec 2018 13:32:44 +0000 (14:32 +0100)
We substitute the path specified in system/skeleton/etc/profile with
the path specified in the configuration variable
$(BR2_SYSTEM_DEFAULT_PATH).

$(BR2_SYSTEM_DEFAULT_PATH) is a Kconfig string, so it is already
double quoted. This means that export PATH=value will now be export
PATH="value" in /etc/profile, which is perfectly fine.

Signed-off-by: Markus Mayer <mmayer@broadcom.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
[Thomas: rework commit log about the double quoting]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/skeleton-init-common/skeleton-init-common.mk
system/skeleton/etc/profile

index e8a0522052689ae4bed263b021233099eb1ef4ab..7d2c68ada308e20d2afd6d8dc2b889f3d966696a 100644 (file)
@@ -20,6 +20,7 @@ define SKELETON_INIT_COMMON_INSTALL_TARGET_CMDS
        $(call SYSTEM_RSYNC,$(SKELETON_INIT_COMMON_PATH),$(TARGET_DIR))
        $(call SYSTEM_USR_SYMLINKS_OR_DIRS,$(TARGET_DIR))
        $(call SYSTEM_LIB_SYMLINK,$(TARGET_DIR))
+       $(SED) 's,@PATH@,$(BR2_SYSTEM_DEFAULT_PATH),' $(TARGET_DIR)/etc/profile
        $(INSTALL) -m 0644 support/misc/target-dir-warning.txt \
                $(TARGET_DIR_WARNING_FILE)
 endef
index 1255d23ff40dfb398050402e807359de271a35a5..db29e44920e8a239f22d3d8b82b76017ceb8c18e 100644 (file)
@@ -1,4 +1,4 @@
-export PATH=/bin:/sbin:/usr/bin:/usr/sbin
+export PATH=@PATH@
 
 if [ "$PS1" ]; then
        if [ "`id -u`" -eq 0 ]; then