package/librsvg: bump to version 2.48.8
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 12 Sep 2020 17:24:00 +0000 (19:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 13 Sep 2020 13:50:47 +0000 (15:50 +0200)
- Add a dependency to host-rustc
- libcroco is not a dependency since
  https://gitlab.gnome.org/GNOME/librsvg/-/commit/03ce9bd7875ef2a91979bc4f7d6fa5188cfd785c
- gtk3 is not a dependency since
  https://gitlab.gnome.org/GNOME/librsvg/-/commit/522aeee0ca9b4ff3940bea2d13ebb77ec6c064a6
- cairo script is mandatory since switch to rust

This bump is needed to remove libcroco which has been archived and won't
get any security updates anymore:
https://gitlab.gnome.org/Archive/libcroco/-/issues/8

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/efl/Config.in
package/enlightenment/Config.in
package/gstreamer1/gst1-plugins-bad/Config.in
package/imagemagick/Config.in.host
package/libgtk3/Config.in
package/librsvg/0001-librsvg.pc.in-add-libcroco-to-Requires.Private.patch [deleted file]
package/librsvg/Config.in
package/librsvg/librsvg.hash
package/librsvg/librsvg.mk
package/midori/Config.in
package/vte/Config.in

index 031bff7ad647d5f43c9b6cbbc6aa68a1653a01e2..c1b19770bb7e68c882d4976776e648cd2ad39c33 100644 (file)
@@ -267,6 +267,7 @@ config BR2_PACKAGE_EFL_LIBRAW
 
 config BR2_PACKAGE_EFL_SVG
        bool "SVG loader"
+       depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS # librsvg
        depends on BR2_TOOLCHAIN_HAS_SYNC_4 # librsvg -> pango -> harfbuzz
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # librsvg -> pango -> harfbuzz
        select BR2_PACKAGE_LIBRSVG
@@ -275,6 +276,7 @@ config BR2_PACKAGE_EFL_SVG
          This option enables the Evas generic SVG loader
 
 comment "SVG loader needs a toolchain w/ gcc >= 4.8"
+       depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
 
index 16304167187a9b16d24290cb5fe847a679621a21..91cdd896f65f7e70941d8b6583a7ddcfab70b71d 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_ENLIGHTENMENT
        bool "enlightenment"
+       depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS # efl svg -> librsvg
        # libevas-generic-loaders-svg -> librsvg -> glib2 / pango
        depends on BR2_USE_WCHAR
        depends on BR2_INSTALL_LIBSTDCPP
@@ -29,6 +30,7 @@ config BR2_PACKAGE_ENLIGHTENMENT
          http://www.enlightenment.org/
 
 comment "enlightenment needs udev /dev management and a toolchain w/ wchar, C++, threads, gcc >= 4.8"
+       depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS
        depends on BR2_PACKAGE_EFL && BR2_PACKAGE_XORG7 && BR2_USE_MMU
        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_INSTALL_LIBSTDCPP || \
                !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 || \
index 5a066cb1791139c5f4db32dcacbdcc3eba7de2bc..d387709de22443f9c5b16082ac9adb2f3330560f 100644 (file)
@@ -531,6 +531,7 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPUS
 
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RSVG
        bool "rsvg"
+       depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS # librsvg
        depends on BR2_INSTALL_LIBSTDCPP # librsvg -> pango
        depends on BR2_TOOLCHAIN_HAS_SYNC_4 # librsvg -> pango -> harfbuzz
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # librsvg -> pango -> harfbuzz
@@ -539,6 +540,7 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RSVG
          RSVG plugin library
 
 comment "rsvg plugin needs a toolchain w/ C++, gcc >= 4.8"
+       depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS
        depends on !BR2_INSTALL_LIBSTDCPP || \
                !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
index bbe23baa6fcb1e892821352bda0a8cfc5e8eac3c..e12d82939a96df4ca22a07b96c35529ef68cf414 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_HOST_IMAGEMAGICK
        bool "host imagemagick"
+       depends on BR2_PACKAGE_HOST_RUSTC_ARCH_SUPPORTS # host-librsvg
        help
          ImageMagick(R) is a software suite to create, edit, and
          compose bitmap images. It can read, convert and write images
index 6b8f5abff6fa5d7cd1993c8ad3e330cd8520c29e..8a59fc31e7408bb3ba893fa7eb83f9cbd957c949 100644 (file)
@@ -1,4 +1,5 @@
 comment "libgtk3 needs a toolchain w/ wchar, threads, C++, gcc >= 4.8"
+       depends on BR2_PACKAGE_HOST_RUSTC_ARCH_SUPPORTS
        depends on BR2_USE_MMU
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP || \
@@ -13,6 +14,7 @@ comment "libgtk3 needs an OpenGL or an OpenGL-EGL/wayland backend"
 
 config BR2_PACKAGE_LIBGTK3
        bool "libgtk3"
+       depends on BR2_PACKAGE_HOST_RUSTC_ARCH_SUPPORTS # host-libgtk3 -> host-librsvg
        depends on BR2_USE_WCHAR # glib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
        depends on BR2_USE_MMU # glib2
diff --git a/package/librsvg/0001-librsvg.pc.in-add-libcroco-to-Requires.Private.patch b/package/librsvg/0001-librsvg.pc.in-add-libcroco-to-Requires.Private.patch
deleted file mode 100644 (file)
index 0eea5b9..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-From 322b415f92d4dcd36824eef83bd617bac6e5c8c7 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Tue, 24 Dec 2019 16:38:35 +0100
-Subject: [PATCH] librsvg.pc.in: add libcroco to Requires.private
-
-libcroco is a mandatory dependency since version 2.35.0 so add it to
-Requires.Private to fix a static build failure with imagemagick
-
-This patch is not upstreamable as librsvg no longer depends on libcroco
-since version 2.47.1. It now does all CSS processing using Rust crates
-from Mozilla Servo.
-
-Fixes:
- - http://autobuild.buildroot.org/results/42f4b4881569779162d3efe4628b934f965913b9
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- librsvg.pc.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/librsvg.pc.in b/librsvg.pc.in
-index a451de05..4b09984a 100644
---- a/librsvg.pc.in
-+++ b/librsvg.pc.in
-@@ -10,6 +10,6 @@ Name: librsvg
- Description: library that renders svg files
- Version: @VERSION@
- Requires: glib-2.0 gio-2.0 gdk-pixbuf-2.0 cairo
--Requires.private:
-+Requires.private: libcroco-0.6
- Libs: -L${libdir} -lrsvg-@RSVG_API_MAJOR_VERSION@ -lm
- Cflags: -I${includedir}/librsvg-@RSVG_API_VERSION@
--- 
-2.24.0
-
index 735bf6125953bcbe5185e92af427a271a49e604b..3272ecd773ea7ccaba5fc3ec948fe07417cb2f96 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_LIBRSVG
        bool "librsvg"
+       depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS
        depends on BR2_USE_WCHAR # glib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
        depends on BR2_USE_MMU # glib2
@@ -8,8 +9,9 @@ config BR2_PACKAGE_LIBRSVG
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # pango -> harfbuzz
        select BR2_PACKAGE_CAIRO
        select BR2_PACKAGE_CAIRO_PNG
+       select BR2_PACKAGE_CAIRO_SCRIPT
        select BR2_PACKAGE_GDK_PIXBUF
-       select BR2_PACKAGE_LIBCROCO
+       select BR2_PACKAGE_HOST_RUSTC
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_LIBXML2
        select BR2_PACKAGE_PANGO
@@ -20,6 +22,7 @@ config BR2_PACKAGE_LIBRSVG
          https://wiki.gnome.org/Projects/LibRsvg
 
 comment "librsvg needs a toolchain w/ wchar, threads, C++, gcc >= 4.8"
+       depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS
        depends on BR2_USE_MMU
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
index 366d9b0db642670152b0134f8c95e0b5db15b8cb..899c5ea76091d30837d468522ce3a163ace1f1b9 100644 (file)
@@ -1,4 +1,5 @@
-# From http://ftp.gnome.org/pub/gnome/sources/librsvg/2.40/librsvg-2.40.20.sha256sum
-sha256 cff4dd3c3b78bfe99d8fcfad3b8ba1eee3289a0823c0e118d78106be6b84c92b        librsvg-2.40.20.tar.xz
+# From http://ftp.gnome.org/pub/gnome/sources/librsvg/2.48/librsvg-2.48.8.sha256sum
+sha256  f480a325bbdf26d1874eb6fb330ebc5920ba64e3e08de61931bb4506dfef2692  librsvg-2.48.8.tar.xz
+
 # Locally computed
 sha256  d7bf9d064ac3e5840f9dd02422b7eeec4f1fd03f37fadbd043602be5e882304f  COPYING.LIB
index e124fdd5d376cb65e74edc69d7a447df7e48b1c2..00be501e933218544f28b9a931e751c3c7f6425e 100644 (file)
@@ -4,18 +4,19 @@
 #
 ################################################################################
 
-LIBRSVG_VERSION_MAJOR = 2.40
-LIBRSVG_VERSION = $(LIBRSVG_VERSION_MAJOR).20
+LIBRSVG_VERSION_MAJOR = 2.48
+LIBRSVG_VERSION = $(LIBRSVG_VERSION_MAJOR).8
 LIBRSVG_SITE = http://ftp.gnome.org/pub/gnome/sources/librsvg/$(LIBRSVG_VERSION_MAJOR)
 LIBRSVG_SOURCE = librsvg-$(LIBRSVG_VERSION).tar.xz
 LIBRSVG_INSTALL_STAGING = YES
-LIBRSVG_CONF_ENV = LIBS=$(TARGET_NLS_LIBS)
+LIBRSVG_CONF_ENV = \
+       LIBS=$(TARGET_NLS_LIBS) \
+       RUST_TARGET=$(RUSTC_TARGET_NAME)
 LIBRSVG_CONF_OPTS = --disable-pixbuf-loader --disable-tools
 HOST_LIBRSVG_CONF_OPTS = --enable-introspection=no
-LIBRSVG_DEPENDENCIES = cairo host-gdk-pixbuf gdk-pixbuf libcroco libglib2 libxml2 pango \
-       $(if $(BR2_PACKAGE_LIBGTK3),libgtk3) \
+LIBRSVG_DEPENDENCIES = cairo host-gdk-pixbuf gdk-pixbuf host-rustc libglib2 libxml2 pango \
        $(TARGET_NLS_DEPENDENCIES)
-HOST_LIBRSVG_DEPENDENCIES = host-cairo host-gdk-pixbuf host-libcroco host-libglib2 host-libxml2 host-pango
+HOST_LIBRSVG_DEPENDENCIES = host-cairo host-gdk-pixbuf host-libglib2 host-libxml2 host-pango host-rustc
 LIBRSVG_LICENSE = LGPL-2.0+
 LIBRSVG_LICENSE_FILES = COPYING.LIB
 
index f4b8905c85f3faaa3960d8794b50aea28876bf01..e2cc2ac612b5cd8fe7f135d40a69b410967871e5 100644 (file)
@@ -1,4 +1,5 @@
 comment "midori needs libgtk3 and a glibc toolchain w/ C++, gcc >= 7, host gcc >= 4.9"
+       depends on BR2_PACKAGE_HOST_RUSTC_ARCH_SUPPORTS
        depends on BR2_PACKAGE_WEBKITGTK_ARCH_SUPPORTS
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_PACKAGE_LIBGTK3 || \
                !BR2_TOOLCHAIN_GCC_AT_LEAST_7 || \
@@ -7,6 +8,7 @@ comment "midori needs libgtk3 and a glibc toolchain w/ C++, gcc >= 7, host gcc >
 
 config BR2_PACKAGE_MIDORI
        bool "midori"
+       depends on BR2_PACKAGE_HOST_RUSTC_ARCH_SUPPORTS # host-librsvg
        depends on BR2_PACKAGE_LIBGPG_ERROR_ARCH_SUPPORTS # libgcrypt, gcr, gnupg2
        depends on BR2_PACKAGE_LIBGTK3
        depends on BR2_HOST_GCC_AT_LEAST_4_9 # webkitgtk
index fa29de8c714b97ab7c1774ea0b80216a3e86f36c..96de3d38ccf2c760e8cb3053edcfcaf77716e368 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_VTE
        bool "vte"
+       depends on BR2_PACKAGE_HOST_RUSTC_ARCH_SUPPORTS # libgtk3 -> host-libgtk3 -> host-librsvg
        depends on BR2_USE_WCHAR
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_USE_MMU
@@ -22,6 +23,7 @@ config BR2_PACKAGE_VTE
          http://github.com/GNOME/vte
 
 comment "vte needs a toolchain w/ wchar, threads, C++, gcc >= 4.8"
+       depends on BR2_PACKAGE_HOST_RUSTC_ARCH_SUPPORTS
        depends on BR2_USE_MMU
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP || \
@@ -29,6 +31,7 @@ comment "vte needs a toolchain w/ wchar, threads, C++, gcc >= 4.8"
                !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
 
 comment "vte needs an OpenGL or an OpenGL-EGL/wayland backend"
+       depends on BR2_PACKAGE_HOST_RUSTC_ARCH_SUPPORTS
        depends on BR2_USE_MMU
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on !BR2_PACKAGE_HAS_LIBEGL_WAYLAND && \