package/openjpeg: bump version to 2.3.0
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 15 Oct 2017 20:27:17 +0000 (22:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 18 Oct 2017 20:09:21 +0000 (22:09 +0200)
Removed patch 0003, applied upstream:
https://github.com/uclouvain/openjpeg/commit/51a1dcaa6ed5713520dca36fc58cd9240c08b7ca

Renamed patch 0004.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Acked-by: Olivier Schonken <olivier.schonken@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openjpeg/0003-CMakeLists.txt-Don-t-require-a-C-compiler.patch [new file with mode: 0644]
package/openjpeg/0003-avoid-malloc-poisoning-issue.patch [deleted file]
package/openjpeg/0004-CMakeLists.txt-Don-t-require-a-C-compiler.patch [deleted file]
package/openjpeg/openjpeg.hash
package/openjpeg/openjpeg.mk

diff --git a/package/openjpeg/0003-CMakeLists.txt-Don-t-require-a-C-compiler.patch b/package/openjpeg/0003-CMakeLists.txt-Don-t-require-a-C-compiler.patch
new file mode 100644 (file)
index 0000000..13cceef
--- /dev/null
@@ -0,0 +1,34 @@
+From 786ddcd1475adc6193c59d53e0d8ed2c502f2b00 Mon Sep 17 00:00:00 2001
+From: Peter Korsgaard <peter@korsgaard.com>
+Date: Sat, 23 Sep 2017 18:49:31 +0200
+Subject: [PATCH] CMakeLists.txt: Don't require a C++ compiler
+
+By default, CMake assumes that the project is using both C and C++.  By
+explicitly passing 'C' as argument of the project() macro, we tell CMake
+that only C is used, which prevents CMake from erroring out if a C++
+compiler doesn't exist.
+
+Submitted upstream:
+https://github.com/uclouvain/openjpeg/pull/1027
+
+Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ec42bc99..d80eb48b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -24,7 +24,7 @@ endif()
+ #string(TOLOWER ${OPENJPEG_NAMESPACE} OPENJPEG_LIBRARY_NAME)
+ set(OPENJPEG_LIBRARY_NAME openjp2)
+-project(${OPENJPEG_NAMESPACE})
++project(${OPENJPEG_NAMESPACE} C)
+ # Do full dependency headers.
+ include_regular_expression("^.*$")
+-- 
+2.11.0
+
diff --git a/package/openjpeg/0003-avoid-malloc-poisoning-issue.patch b/package/openjpeg/0003-avoid-malloc-poisoning-issue.patch
deleted file mode 100644 (file)
index 8463e20..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-From 51a1dcaa6ed5713520dca36fc58cd9240c08b7ca Mon Sep 17 00:00:00 2001
-From: Even Rouault <even.rouault@spatialys.com>
-Date: Thu, 7 Sep 2017 17:52:59 +0200
-Subject: [PATCH] Avoid malloc poisoning issue when including <pthread.h> of
- uclibc (#1013)
-
-Signed-off-by: Olivier Schonken <olivier.schonken@gmail.com>
----
- src/lib/openjp2/thread.c | 11 ++++++++---
- 1 file changed, 8 insertions(+), 3 deletions(-)
-
-diff --git a/src/lib/openjp2/thread.c b/src/lib/openjp2/thread.c
-index 8b56aa4d5..af33c2c80 100644
---- a/src/lib/openjp2/thread.c
-+++ b/src/lib/openjp2/thread.c
-@@ -29,9 +29,6 @@
-  * POSSIBILITY OF SUCH DAMAGE.
-  */
--#include "opj_includes.h"
--
--#include "thread.h"
- #include <assert.h>
- #ifdef MUTEX_win32
-@@ -46,6 +43,8 @@
- #include <windows.h>
- #include <process.h>
-+#include "opj_includes.h"
-+
- OPJ_BOOL OPJ_CALLCONV opj_has_thread_support(void)
- {
-     return OPJ_TRUE;
-@@ -289,6 +288,10 @@ void opj_thread_join(opj_thread_t* thread)
- #include <stdlib.h>
- #include <unistd.h>
-+/* Moved after all system includes, and in particular pthread.h, so as to */
-+/* avoid poisoning issuing with malloc() use in pthread.h with ulibc (#1013) */
-+#include "opj_includes.h"
-+
- OPJ_BOOL OPJ_CALLCONV opj_has_thread_support(void)
- {
-     return OPJ_TRUE;
-@@ -425,6 +428,8 @@ void opj_thread_join(opj_thread_t* thread)
- #else
- /* Stub implementation */
-+#include "opj_includes.h"
-+
- OPJ_BOOL OPJ_CALLCONV opj_has_thread_support(void)
- {
-     return OPJ_FALSE;
diff --git a/package/openjpeg/0004-CMakeLists.txt-Don-t-require-a-C-compiler.patch b/package/openjpeg/0004-CMakeLists.txt-Don-t-require-a-C-compiler.patch
deleted file mode 100644 (file)
index 13cceef..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From 786ddcd1475adc6193c59d53e0d8ed2c502f2b00 Mon Sep 17 00:00:00 2001
-From: Peter Korsgaard <peter@korsgaard.com>
-Date: Sat, 23 Sep 2017 18:49:31 +0200
-Subject: [PATCH] CMakeLists.txt: Don't require a C++ compiler
-
-By default, CMake assumes that the project is using both C and C++.  By
-explicitly passing 'C' as argument of the project() macro, we tell CMake
-that only C is used, which prevents CMake from erroring out if a C++
-compiler doesn't exist.
-
-Submitted upstream:
-https://github.com/uclouvain/openjpeg/pull/1027
-
-Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ec42bc99..d80eb48b 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -24,7 +24,7 @@ endif()
- #string(TOLOWER ${OPENJPEG_NAMESPACE} OPENJPEG_LIBRARY_NAME)
- set(OPENJPEG_LIBRARY_NAME openjp2)
--project(${OPENJPEG_NAMESPACE})
-+project(${OPENJPEG_NAMESPACE} C)
- # Do full dependency headers.
- include_regular_expression("^.*$")
--- 
-2.11.0
-
index 0e51aaec5ea470a1fc43b6a19ca8d756a42c16a1..dd3cf26cf03d39b10bf4904432aaaf79e58a19b1 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed:
-sha256 6fddbce5a618e910e03ad00d66e7fcd09cc6ee307ce69932666d54c73b7c6e7b  openjpeg-2.2.0.tar.gz
+sha256 3dc787c1bb6023ba846c2a0d9b1f6e179f1cd255172bde9eb75b01f1e6c7d71a  openjpeg-2.3.0.tar.gz
index eff012f7629d431207a0ee5e938eb755028eb749..df85168b801769dd52312b0f183469af8cf95c21 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-OPENJPEG_VERSION = 2.2.0
+OPENJPEG_VERSION = 2.3.0
 OPENJPEG_SITE = $(call github,uclouvain,openjpeg,v$(OPENJPEG_VERSION))
 OPENJPEG_LICENSE = BSD-2-Clause
 OPENJPEG_LICENSE_FILES = LICENSE