package/imx-uuc: fix static build with musl
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 7 Jul 2019 13:55:32 +0000 (15:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 14 Jul 2019 13:59:49 +0000 (15:59 +0200)
Use TARGET_CONFIGURE_OPTS to pass -static in LDFLAGS when building
statically

Fixes:
 - http://autobuild.buildroot.org/results/12c08173f83315fb68fe3c3d34a78ed919ba5a79

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/freescale-imx/imx-uuc/imx-uuc.mk

index 52d2b7c7a3abf750525522619bddfae532a945af..e94648b832f5e5dde964d424227e873a28b993e0 100644 (file)
@@ -14,7 +14,7 @@ IMX_UUC_LICENSE_FILES = COPYING
 IMX_UUC_DEPENDENCIES = host-dosfstools
 
 define IMX_UUC_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) CC=$(TARGET_CC)
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
 endef
 
 define IMX_UUC_INSTALL_TARGET_CMDS