openldap: supports only the real OpenSSL, not LibreSSL
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 16:51:50 +0000 (18:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 19:28:13 +0000 (21:28 +0200)
openldap will not build with LibreSSL without patches, so let's
support only OpenSSL.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openldap/openldap.mk

index 90ff1123b4f6874c78526eeae20f35cfc8f87260..56066f9133b3b6fb9ee2f67e808180d9a04a1bdc 100644 (file)
@@ -12,8 +12,8 @@ OPENLDAP_LICENSE_FILES = LICENSE
 OPENLDAP_INSTALL_STAGING = YES
 OPENLDAP_DEPENDENCIES = host-pkgconf
 
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
-OPENLDAP_TLS = openssl
+ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
+OPENLDAP_TLS = libopenssl
 OPENLDAP_DEPENDENCIES += openssl
 else ifeq ($(BR2_PACKAGE_GNUTLS),y)
 OPENLDAP_TLS = gnutls