smcroute: new package
authorMatt Weber <mlweber1@rockwellcollins.com>
Mon, 16 Dec 2013 15:58:21 +0000 (09:58 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 16 Dec 2013 20:32:29 +0000 (21:32 +0100)
Signed-off-by: Matt Weber <mlweber1@rockwellcollins.com>
Signed-off-by: Sean Gerhardt <sagerhar@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/smcroute/Config.in [new file with mode: 0755]
package/smcroute/smcroute.mk [new file with mode: 0755]

index be167145c0b8f5d402910ad54f4392f46c61702d..78a9e1605708e9f5feeb1b6e00fedbde1a1fef69 100644 (file)
@@ -891,6 +891,7 @@ source "package/rtptools/Config.in"
 source "package/samba/Config.in"
 source "package/sconeserver/Config.in"
 source "package/ser2net/Config.in"
+source "package/smcroute/Config.in"
 source "package/socat/Config.in"
 source "package/socketcand/Config.in"
 source "package/spawn-fcgi/Config.in"
diff --git a/package/smcroute/Config.in b/package/smcroute/Config.in
new file mode 100755 (executable)
index 0000000..df42db3
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_SMCROUTE
+       bool "smcroute"
+       depends on BR2_INET_IPV6
+       help
+         SMCRoute is a command line tool to manipulate the multicast
+         routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast
+         routing.  SMCRoute can be used as an alternative to dynamic
+         multicast routers like mrouted or pimd in setups where static
+         multicast routes should be maintained and/or no proper IGMP or
+         MLD signaling exists.
+
+         https://github.com/troglobit/smcroute
+
+comment "smcroute needs a toolchain w/ IPv6"
+       depends on !BR2_INET_IPV6
diff --git a/package/smcroute/smcroute.mk b/package/smcroute/smcroute.mk
new file mode 100755 (executable)
index 0000000..63a44c9
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# smcroute
+#
+################################################################################
+
+SMCROUTE_VERSION = 1.99.2
+SMCROUTE_SITE = $(call github,troglobit,smcroute,$(SMCROUTE_VERSION))
+SMCROUTE_LICENSE = GPLv2+
+SMCROUTE_LICENSE_FILES = COPYING
+
+SMCROUTE_CONF_OPT = ac_cv_func_setpgrp_void=yes
+#BUG:The package Makefile uses CC?= even though the package is autotools based
+SMCROUTE_MAKE_ENV = $(TARGET_CONFIGURE_OPTS)
+
+$(eval $(autotools-package))