gst1-plugins-good: bump version
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 7 Sep 2014 21:03:58 +0000 (23:03 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 7 Sep 2014 21:03:58 +0000 (23:03 +0200)
And cleanup X11 handling while we're at it.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gst1-plugins-good/Config.in
package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk

index 22980dcd34257f03f5f889085c070295cadb9583..73c633fa4846eb0ec817cb29d97d165d22934e23 100644 (file)
@@ -1,6 +1,9 @@
 menuconfig BR2_PACKAGE_GST1_PLUGINS_GOOD
        bool "gst1-plugins-good"
        select BR2_PACKAGE_GST1_PLUGINS_BASE
+       select BR2_PACKAGE_XLIB_LIBX11 if BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_XLIB_LIBXEXT if BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_XLIB_LIBXV if BR2_PACKAGE_XORG7
        help
          A set of well-supported plug-ins for GStreamer under the preferred
          license.
index 2cf8ca8bcbd4cacd04aa19e5fb0e3e20b4ab15d4..23d3876c4b35d6db19c64226076af5d6d422b303 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GST1_PLUGINS_GOOD_VERSION = 1.2.4
+GST1_PLUGINS_GOOD_VERSION = 1.4.1
 GST1_PLUGINS_GOOD_SOURCE = gst-plugins-good-$(GST1_PLUGINS_GOOD_VERSION).tar.xz
 GST1_PLUGINS_GOOD_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-good
 GST1_PLUGINS_GOOD_LICENSE_FILES = COPYING
@@ -322,12 +322,12 @@ GST1_PLUGINS_GOOD_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXv
 GST1_PLUGINS_GOOD_CONF_OPT += \
        --enable-x \
        --enable-xshm \
-       --enable-xvideo
+       $(if $(BR2_PACKAGE_XLIB_LIBXFIXES),xlib_libXfixes) \
+       $(if $(BR2_PACKAGE_XLIB_LIBXDAMAGE),xlib_libXdamage)
 else
 GST1_PLUGINS_GOOD_CONF_OPT += \
        --disable-x \
-       --disable-xshm \
-       --disable-xvideo
+       --disable-xshm
 endif
 
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_CAIRO),y)