usbutils: fix recursive LIBUSB Kconfig issue and bump to 0.87
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 6 May 2010 14:14:38 +0000 (11:14 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 6 May 2010 21:03:18 +0000 (23:03 +0200)
Closes #1699

[Peter: Use BR2_KERNEL_MIRROR]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/usbutils/Config.in
package/usbutils/usbutils.mk

diff --git a/CHANGES b/CHANGES
index 19cb48676b045fc444e5460c2d7e2ea31adb4435..525db270fb467fc241e772eba20581f972d30902 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -3,12 +3,13 @@
        Fixes all over the tree.
 
        Updated/fixed packages: hal, mplayer,
-       xdriver_xf86-video-openchrome, usb_modeswitch
+       xdriver_xf86-video-openchrome, usb_modeswitch, usbutils
 
        Issues resolved (http://bugs.uclibc.org):
 
        #985: Bump usb_modeswitch package to 1.1.0
        #1525: Package hal deletes a whole <target>/etc/rc.d directory
+       #1699: Fix usbutils dependencies and bump
 
 2010.05-rc1, Released May 3rd, 2010:
 
index 6e5435277b0aa74f1e89b8e4f2a114acb8367f7a..427325231d611d6f311732003d35bbc77bfe36f0 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_USBUTILS
        bool "usbutils"
+       select BR2_PACKAGE_LIBUSB
        select BR2_PACKAGE_LIBUSB_COMPAT
        help
          USB enumeration utilities
index 880a2c843c1ed8902b57a7266e1555684479bed8..f0952976efee9d12710c33490a316e99cf1406ec 100644 (file)
@@ -4,8 +4,8 @@
 #
 #############################################################
 
-USBUTILS_VERSION = 0.86
-USBUTILS_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/linux-usb/
+USBUTILS_VERSION = 0.87
+USBUTILS_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/usb/usbutils
 USBUTILS_DEPENDENCIES = host-pkg-config libusb-compat
 
 ifeq ($(BR2_PACKAGE_USBUTILS_ZLIB),y)
@@ -24,5 +24,8 @@ ifeq ($(BR2_PACKAGE_USBUTILS_ZLIB),y)
        rm -f $(TARGET_DIR)/usr/share/usb.ids
 else
        rm -f $(TARGET_DIR)/usr/share/usb.ids.gz
+endif
+ifneq ($(BR2_HAVE_DEVFILES),y)
+       rm -f $(TARGET_DIR)/usr/bin/libusb-config
 endif
        touch $@