pkg-cmake: Skip compilation in installation step
authorCédric Marie <cedric.marie@openmailbox.org>
Wed, 22 Apr 2015 20:11:56 +0000 (22:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Apr 2015 07:50:16 +0000 (09:50 +0200)
With CMake build system, the "make install" command always compiles
before installing, to make sure that everything is up-to-date.

In Buildroot environment, this is quite useless, because the package
has always already been compiled, either at first build, or when
invoking "make <package>-rebuild".
In all cases, when it comes to staging or target installation step, the
package has just been compiled.

Using "make install/fast" - in order to skip the compilation step - is
therefore more appropriate, more consistent with what other build
systems do, and saves time when you need to rebuild your package.

Signed-off-by: Cédric Marie <cedric.marie@openmailbox.org>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-cmake.mk

index 2262012483918b66d3ae77a9a51d955de1723523..f17a88331201bf22a06f350fd6aa833f28cc40c6 100644 (file)
@@ -57,8 +57,8 @@ $(2)_MAKE                     ?= $$(MAKE)
 $(2)_MAKE_ENV                  ?=
 $(2)_MAKE_OPTS                 ?=
 $(2)_INSTALL_OPTS              ?= install
-$(2)_INSTALL_STAGING_OPTS      ?= DESTDIR=$$(STAGING_DIR) install
-$(2)_INSTALL_TARGET_OPTS               ?= DESTDIR=$$(TARGET_DIR) install
+$(2)_INSTALL_STAGING_OPTS      ?= DESTDIR=$$(STAGING_DIR) install/fast
+$(2)_INSTALL_TARGET_OPTS               ?= DESTDIR=$$(TARGET_DIR) install/fast
 
 $(2)_SRCDIR                    = $$($(2)_DIR)/$$($(2)_SUBDIR)