- add first hunk to fix PR30620
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 10 Feb 2007 19:36:25 +0000 (19:36 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 10 Feb 2007 19:36:25 +0000 (19:36 -0000)
toolchain/gcc/4.2/402-libbackend_dep_gcov-iov.h.patch [new file with mode: 0644]

diff --git a/toolchain/gcc/4.2/402-libbackend_dep_gcov-iov.h.patch b/toolchain/gcc/4.2/402-libbackend_dep_gcov-iov.h.patch
new file mode 100644 (file)
index 0000000..0bf115c
--- /dev/null
@@ -0,0 +1,13 @@
+Index: gcc-4.2/gcc/Makefile.in
+===================================================================
+--- gcc-4.2/gcc/Makefile.in    (revision 121758)
++++ gcc-4.2/gcc/Makefile.in    (working copy)
+@@ -2658,7 +2658,7 @@ mips-tdump.o : mips-tdump.c $(CONFIG_H) 
+ # FIXME: writing proper dependencies for this is a *LOT* of work.
+ libbackend.o : $(OBJS-common:.o=.c) $(out_file) \
+   insn-config.h insn-flags.h insn-codes.h insn-constants.h \
+-  insn-attr.h  $(DATESTAMP) $(BASEVER) $(DEVPHASE)
++  insn-attr.h  $(DATESTAMP) $(BASEVER) $(DEVPHASE) gcov-iov.h
+       $(CC) $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
+         -DTARGET_NAME=\"$(target_noncanonical)\" \
+         -DLOCALEDIR=\"$(localedir)\" \