perl-json-tiny: new package
authorFrancois Perrad <fperrad@gmail.com>
Tue, 22 Jul 2014 18:17:54 +0000 (20:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 23 Jul 2014 19:46:16 +0000 (21:46 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/perl-json-tiny/Config.in [new file with mode: 0644]
package/perl-json-tiny/perl-json-tiny.mk [new file with mode: 0644]

index aa2f783ce99637fd22a067ce4ec36410883f4097..b89a98ee960309239417ed7f069448d02d4c9569 100644 (file)
@@ -436,6 +436,7 @@ menu "Perl libraries/modules"
        source "package/perl-gdgraph/Config.in"
        source "package/perl-gdtextutil/Config.in"
        source "package/perl-io-socket-ssl/Config.in"
+       source "package/perl-json-tiny/Config.in"
        source "package/perl-mojolicious/Config.in"
        source "package/perl-net-ssleay/Config.in"
        source "package/perl-xml-libxml/Config.in"
diff --git a/package/perl-json-tiny/Config.in b/package/perl-json-tiny/Config.in
new file mode 100644 (file)
index 0000000..ce943ca
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PERL_JSON_TINY
+       bool "perl-json-tiny"
+       help
+         Minimalistic JSON. No dependencies.
+
+         https://metacpan.org/release/JSON-Tiny
diff --git a/package/perl-json-tiny/perl-json-tiny.mk b/package/perl-json-tiny/perl-json-tiny.mk
new file mode 100644 (file)
index 0000000..fd99ee7
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-json-tiny
+#
+################################################################################
+
+PERL_JSON_TINY_VERSION = 0.49
+PERL_JSON_TINY_SOURCE = JSON-Tiny-$(PERL_JSON_TINY_VERSION).tar.gz
+PERL_JSON_TINY_SITE = $(BR2_CPAN_MIRROR)/authors/id/D/DA/DAVIDO/
+PERL_JSON_TINY_DEPENDENCIES = perl
+PERL_JSON_TINY_LICENSE = Artistic-2.0
+PERL_JSON_TINY_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))