avahi: fix avahi access through dbus
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 28 Feb 2011 14:53:49 +0000 (15:53 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 28 Feb 2011 15:04:54 +0000 (16:04 +0100)
Ensure that the avahi dbus service gets installed if dbus support is
enabled, otherwise avahi access through dbus fails (as clients try
to start the daemon and dbus doesn't know how to do this).

Fixed upstream in 0.6.28 (http://avahi.org/ticket/319) but this
workaround is simpler/safer for now.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/avahi/avahi.mk

index 8c0d920e9ee985a69e705b9f30945fcf2ca5b081..63215572cb95a47e6b03a9ff0f6594cd868b0e0b 100644 (file)
@@ -160,8 +160,19 @@ define AVAHI_INSTALL_DAEMON_INITSCRIPT
        $(INSTALL) -m 0755 package/avahi/S50avahi-daemon $(TARGET_DIR)/etc/init.d/
 endef
 
+# avahi build sys erroneously only installs dbus service if systemd is enabled
+define AVAHI_INSTALL_DAEMON_DBUS_SERVICE
+       $(INSTALL) -m 0644 -D $(@D)/avahi-daemon/org.freedesktop.Avahi.service \
+               $(TARGET_DIR)/usr/share/dbus-1/system-services/org.freedesktop.Avahi.service
+endef
+
 ifeq ($(BR2_PACKAGE_AVAHI_DAEMON),y)
 AVAHI_POST_INSTALL_TARGET_HOOKS += AVAHI_INSTALL_DAEMON_INITSCRIPT
+
+ifeq ($(BR2_PACKAGE_DBUS),y)
+AVAHI_POST_INSTALL_TARGET_HOOKS += AVAHI_INSTALL_DAEMON_DBUS_SERVICE
+endif
+
 endif
 
 $(eval $(call AUTOTARGETS,package,avahi))