gcc: disable libsanitizer for sparc
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 15 Apr 2015 19:41:56 +0000 (16:41 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 16 Apr 2015 05:59:40 +0000 (07:59 +0200)
Normally libsanitizer handles the different functionalities gracefully for
each architecture, but it doesn't seem to be the case for SPARC.
Since in general it doesn't support anything for SPARC just disable it.

Fixes bug #7951.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gcc/gcc.mk

index 24fd7b8778c3e16ed3b49fdfd8166262a202db5c..be242cb6df1e4e84c5bd41b0fbe89ff4180d3164 100644 (file)
@@ -126,6 +126,12 @@ ifeq ($(BR2_TOOLCHAIN_BUILDROOT_UCLIBC)$(BR2_TOOLCHAIN_BUILDROOT_MUSL),y)
 HOST_GCC_COMMON_CONF_OPTS += --disable-libsanitizer
 endif
 
+# libsanitizer is broken for SPARC
+# https://bugs.busybox.net/show_bug.cgi?id=7951
+ifeq ($(BR2_sparc),y)
+HOST_GCC_COMMON_CONF_OPTS += --disable-libsanitizer
+endif
+
 ifeq ($(BR2_GCC_ENABLE_TLS),y)
 HOST_GCC_COMMON_CONF_OPTS += --enable-tls
 else