cjson: fix build for toolchains without ssp
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 28 Feb 2017 22:26:07 +0000 (23:26 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Mar 2017 20:48:41 +0000 (21:48 +0100)
Set ENABLE_CUSTOM_COMPILER_FLAGS to OFF to disable custom flags, in
particular -fstack-protector-strong which depends on
BR2_TOOLCHAIN_HAS_SSP

Fixes:

  http://autobuild.buildroot.net/results/cfcf3bc8066159dfddd1786954d78e8527858f2f/

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cjson/cjson.mk

index aea957852644ec5442412aaea405d1bb0b5c62b0..c554654805c4ea29f6d1321474883a8a17c960bd 100644 (file)
@@ -9,7 +9,10 @@ CJSON_SITE = $(call github,DaveGamble,cjson,$(CJSON_VERSION))
 CJSON_INSTALL_STAGING = YES
 CJSON_LICENSE = MIT
 CJSON_LICENSE_FILES = LICENSE
+# Set ENABLE_CUSTOM_COMPILER_FLAGS to OFF in particular to disable
+# -fstack-protector-strong which depends on BR2_TOOLCHAIN_HAS_SSP
 CJSON_CONF_OPTS += \
-       -DENABLE_CJSON_TEST=OFF
+       -DENABLE_CJSON_TEST=OFF \
+       -DENABLE_CUSTOM_COMPILER_FLAGS=OFF
 
 $(eval $(cmake-package))