package/ripgrep: depends on host-rustc
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Fri, 7 Feb 2020 18:08:25 +0000 (19:08 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 27 Jul 2020 11:31:00 +0000 (13:31 +0200)
As all providers of rustc also install cargo, there is no need to depend
on the standalone cargo package anymore. Instead add host-rustc to the
dependency list.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Patrick Havelange <patrick.havelange@essensium.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Reviewed-by: David Pierret <david.pierret@smile.fr>
Tested-by: David Pierret <david.pierret@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ripgrep/Config.in
package/ripgrep/ripgrep.mk

index 5446ad046c941460225acc44348fc222aa971a48..0ea2902b34d1c3a770d592c4c03bc4961075475b 100644 (file)
@@ -1,7 +1,7 @@
 config BR2_PACKAGE_RIPGREP
        bool "ripgrep"
        depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS
-       select BR2_PACKAGE_HOST_CARGO
+       select BR2_PACKAGE_HOST_RUSTC
        help
          ripgrep is a line-oriented search tool that
          recursively searches your current directory
index 0bb7017a96b1c27c2f01c535639a0f56320752e1..832c076f26bbc4dcbe9cdf2a39970ff978930533 100644 (file)
@@ -9,7 +9,7 @@ RIPGREP_SITE = $(call github,burntsushi,ripgrep,$(RIPGREP_VERSION))
 RIPGREP_LICENSE = MIT
 RIPGREP_LICENSE_FILES = LICENSE-MIT
 
-RIPGREP_DEPENDENCIES = host-cargo
+RIPGREP_DEPENDENCIES = host-rustc
 RIPGREP_CARGO_ENV = CARGO_HOME=$(HOST_DIR)/share/cargo
 RIPGREP_CARGO_MODE = $(if $(BR2_ENABLE_DEBUG),debug,release)