gst-plugins: ivborbis (aka tremor) moved to gst-plugins-base
authorSven Neumann <s.neumann@raumfeld.com>
Thu, 7 Jul 2011 07:39:01 +0000 (09:39 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 7 Jul 2011 08:55:54 +0000 (10:55 +0200)
The integer vorbis decoder moved from gst-plugins-bad to
gst-plugins-base.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst-plugins-bad/Config.in
package/multimedia/gst-plugins-bad/gst-plugins-bad.mk
package/multimedia/gst-plugins-base/Config.in
package/multimedia/gst-plugins-base/gst-plugins-base.mk

index e25b756dfec110eeb719fb34bef7652e0f95bd58..23d59162d434d44b0842da1bac4f21352bac25fe 100644 (file)
@@ -192,10 +192,6 @@ config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SDL
        bool "sdl"
        select BR2_PACKAGE_SDL
 
-config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_TREMOR
-       bool "tremor"
-       select BR2_PACKAGE_TREMOR
-
 config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VCD
        bool "vcd"
 
index 31d998f9b21d0ac5ea4a5bd995054ec1b4b61947..5bbb53a78660c30ceab73551f800a4642e505add 100644 (file)
@@ -355,13 +355,6 @@ else
 GST_PLUGINS_BAD_CONF_OPT += --disable-sdl
 endif
 
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_TREMOR),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-ivorbis
-GST_PLUGINS_BAD_DEPENDENCIES += tremor
-else
-GST_PLUGINS_BAD_CONF_OPT += --disable-ivorbis
-endif
-
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VCD),y)
 GST_PLUGINS_BAD_CONF_OPT += --enable-vcd
 else
index 3ac4dac085407bb6826f93fa822eabdc5da7c3f8..851337b05fb5cdc639ac19b4b7e5ddc95d95649f 100644 (file)
@@ -86,6 +86,10 @@ config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_THEORA
        bool "theora (*.ogg video)"
        select BR2_PACKAGE_LIBTHEORA
 
+config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_TREMOR
+       bool "tremor"
+       select BR2_PACKAGE_TREMOR
+
 config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VORBIS
        bool "vorbis (*.ogg audio)"
        select BR2_PACKAGE_LIBVORBIS
index 72188736c5911734d2b5b49a1a8235b356b782c1..79ced3004ae4926a94fb8496cc26bfd3bed461d3 100644 (file)
@@ -156,6 +156,13 @@ else
 GST_PLUGINS_BASE_CONF_OPT += --disable-theora
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_TREMOR),y)
+GST_PLUGINS_BASE_CONF_OPT += --enable-ivorbis
+GST_PLUGINS_BASE_DEPENDENCIES += tremor
+else
+GST_PLUGINS_BASE_CONF_OPT += --disable-ivorbis
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VORBIS),y)
 GST_PLUGINS_BASE_CONF_OPT += --enable-vorbis
 GST_PLUGINS_BASE_DEPENDENCIES += libvorbis