luajit: fix host installation
authorRomain Naour <romain.naour@gmail.com>
Sun, 1 May 2016 21:22:08 +0000 (23:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 May 2016 21:29:56 +0000 (23:29 +0200)
Packages installed for the host should have their prefix set to
$(HOST_DIR)/usr, and therefore not use DESTDIR at installation time.

Using PREFIX=/usr DESTDIR=$(HOST_DIR) is wrong, and leads for example to
luajit.pc containing prefix=/usr, which means pkg-config returns
incorrect results for host-luajit.

This patch fixes the luajit package to conform to this rule.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
[Thomas: rewrite commit log.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/luajit/luajit.mk

index 623bfcc5f7b1e6d24eff708644c696c50337f0eb..81a26603cb682372262b1caf107ca9a6d53b363b 100644 (file)
@@ -66,13 +66,13 @@ LUAJIT_POST_INSTALL_TARGET_HOOKS += LUAJIT_INSTALL_SYMLINK
 
 # host-efl package needs host-luajit to be linked dynamically.
 define HOST_LUAJIT_BUILD_CMDS
-       $(MAKE) PREFIX="/usr" BUILDMODE=dynamic \
+       $(MAKE) PREFIX="$(HOST_DIR)/usr" BUILDMODE=dynamic \
                TARGET_LDFLAGS="$(HOST_LDFLAGS)" \
                -C $(@D) amalg
 endef
 
 define HOST_LUAJIT_INSTALL_CMDS
-       $(MAKE) PREFIX="/usr" DESTDIR="$(HOST_DIR)" LDCONFIG=true -C $(@D) install
+       $(MAKE) PREFIX="$(HOST_DIR)/usr" LDCONFIG=true -C $(@D) install
 endef
 
 $(eval $(generic-package))