ebtables: build fix for 64-bit kernel with 32-bit userland
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 25 Oct 2013 13:10:23 +0000 (10:10 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Oct 2013 21:59:30 +0000 (22:59 +0100)
Fixes bug #6602.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ebtables/ebtables.mk

index edb5d42b75663eda90f89b35c6895f6b5c271ee7..612cf830239230e39e2729785677ffe833e0a4c3 100644 (file)
@@ -10,10 +10,11 @@ EBTABLES_SITE = http://downloads.sourceforge.net/project/ebtables/ebtables/ebtab
 EBTABLES_LICENSE = GPLv2+
 EBTABLES_LICENSE_FILES = COPYING
 EBTABLES_STATIC = $(if $(BR2_PREFER_STATIC_LIB),static)
+EBTABLES_K64U32 = $(if $(BR2_KERNEL_64_USERLAND_32),CFLAGS+="-DKERNEL_64_USERSPACE_32")
 
 define EBTABLES_BUILD_CMDS
        $(MAKE) $(TARGET_CONFIGURE_OPTS) LIBDIR=/lib/ebtables $(EBTABLES_STATIC) \
-               -C $(@D)
+               $(EBTABLES_K64U32) -C $(@D)
 endef
 
 ifeq ($(BR2_PREFER_STATIC_LIB),y)