php: install configuration file unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:59 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:40:22 +0000 (00:40 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

[Peter: use install -D]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/php/php.mk

index ae959db466587706ae711657ddfcdf68b23b034d..e6ea65fb66952cd6068dc45c29cf12cb08097762 100644 (file)
@@ -238,10 +238,8 @@ PHP_POST_INSTALL_TARGET_HOOKS += PHP_EXTENSIONS_FIXUP
 define PHP_INSTALL_FIXUP
        rm -rf $(TARGET_DIR)/usr/lib/php
        rm -f $(TARGET_DIR)/usr/bin/phpize
-       if [ ! -f $(TARGET_DIR)/etc/php.ini ]; then \
-               $(INSTALL) -m 0755  $(PHP_DIR)/php.ini-production \
-                       $(TARGET_DIR)/etc/php.ini; \
-       fi
+       $(INSTALL) -D -m 0755 $(PHP_DIR)/php.ini-production \
+               $(TARGET_DIR)/etc/php.ini
 endef
 
 PHP_POST_INSTALL_TARGET_HOOKS += PHP_INSTALL_FIXUP