php: fix libxml2 build failure
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 26 Apr 2013 02:39:50 +0000 (02:39 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 26 Apr 2013 14:42:06 +0000 (16:42 +0200)
The libxml2 build test uses the PHP_TEST_BUILD macro which in turn uses
AC_TRY_RUN which is bad for cross compilations.
Force php_cv_libxml_build_works to yes when libxml2 is selected. Fixes:
http://autobuild.buildroot.net/results/8b45a1260ab6ae15dc59a5d6b5b98698ec3e7bbe/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/php/php.mk

index ba428a664b3f2477888080de1e8276585711d56b..2a452d1401f82762dffae0dc2841c9c26e7662bd 100644 (file)
@@ -66,6 +66,7 @@ ifeq ($(BR2_PACKAGE_PHP_EXT_OPENSSL),y)
 endif
 
 ifeq ($(BR2_PACKAGE_PHP_EXT_LIBXML2),y)
+       PHP_CONF_ENV += php_cv_libxml_build_works=yes
        PHP_CONF_OPT += --enable-libxml --with-libxml-dir=${STAGING_DIR}/usr
        PHP_DEPENDENCIES += libxml2
 endif