package/perl: link with -lintl if needed
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 21 Feb 2021 17:45:49 +0000 (18:45 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 2 Mar 2021 20:59:50 +0000 (21:59 +0100)
Link with TARGET_NLS_LIBS if needed to avoid the following build failure
with perl in version 5.32:

/home/buildroot/autobuild/instance-3/output-1/host/bin/arm-linux-gcc -lm -Wl,-E -o perl perlmain.o libperl.a  -lm -lcrypt -lpthread -ldl
/home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/arm-buildroot-linux-uclibcgnueabi/9.3.0/../../../../arm-buildroot-linux-uclibcgnueabi/bin/ld: libperl.a(locale.o): in function `S_emulate_setlocale':
/home/buildroot/autobuild/instance-3/output-1/build/perl-5.32.1/locale.c:1182: undefined reference to `libintl_textdomain'

An upstream issue has been opened in:
https://github.com/Perl/perl5/issues/18467

Fixes:
 - http://autobuild.buildroot.org/results/9df8d8d28006845b4f927548f8856dfa8f79802b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/perl/perl.mk

index ec1cfd4d0a93910cf3ddad9c3b877a6329dbae3f..0ff288db0e0b86b429400129e757d9fce8e87734 100644 (file)
@@ -11,6 +11,7 @@ PERL_SITE = https://www.cpan.org/src/5.0
 PERL_SOURCE = perl-$(PERL_VERSION).tar.xz
 PERL_LICENSE = Artistic or GPL-1.0+
 PERL_LICENSE_FILES = Artistic Copying README
+PERL_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
 PERL_INSTALL_STAGING = YES
 
 PERL_CROSS_VERSION = 1.3.5
@@ -50,7 +51,7 @@ PERL_CONF_OPTS = \
        --prefix=/usr \
        -Dld="$(TARGET_CC)" \
        -Dccflags="$(TARGET_CFLAGS)" \
-       -Dldflags="$(TARGET_LDFLAGS) -lm" \
+       -Dldflags="$(TARGET_LDFLAGS) -lm $(TARGET_NLS_LIBS)" \
        -Dmydomain="" \
        -Dmyhostname="noname" \
        -Dmyuname="Buildroot $(BR2_VERSION_FULL)" \