dos2unix: use new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 14:59:50 +0000 (16:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:27:24 +0000 (01:27 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - using TARGET_NLS_LIBS to force linking against libintl

 - dropping BR2_PACKAGE_GETTEXT selection

In addition, we now use BR2_SYSTEM_ENABLE_NLS instead of
BR2_ENABLE_LOCALE to decide if NLS support should be enabled or
disabled.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dos2unix/Config.in
package/dos2unix/dos2unix.mk

index 6945f52fadde8a43e3a5cb854057547813d8b0aa..cfb5ba4b7961ebce37403122317346103efd6e46 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_DOS2UNIX
        bool "dos2unix"
        depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          dos2unix converts text file line endings between CRLF and LF
 
index 3540ec85628e6b8860806157ec247b81ec951df9..87525fb468a95fa91fe665839b8baa69115cd3b3 100644 (file)
@@ -8,19 +8,18 @@ DOS2UNIX_VERSION = 7.3.4
 DOS2UNIX_SITE = http://waterlan.home.xs4all.nl/dos2unix
 DOS2UNIX_LICENSE = BSD-2-Clause
 DOS2UNIX_LICENSE_FILES = COPYING.txt
-DOS2UNIX_DEPENDENCIES = $(if $(BR2_PACKAGE_BUSYBOX),busybox)
+DOS2UNIX_DEPENDENCIES = \
+       $(if $(BR2_PACKAGE_BUSYBOX),busybox) \
+       $(TARGET_NLS_DEPENDENCIES)
 
-ifeq ($(BR2_ENABLE_LOCALE),y)
-DOS2UNIX_DEPENDENCIES += host-gettext
+ifeq ($(BR2_SYSTEM_ENABLE_NLS),y)
+DOS2UNIX_MAKE_OPTS += ENABLE_NLS=1
+DOS2UNIX_MAKE_OPTS += LIBS_EXTRA=$(TARGET_NLS_LIBS)
 else
+# Should be defined to empty to disable NLS support
 DOS2UNIX_MAKE_OPTS += ENABLE_NLS=
 endif
 
-ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
-DOS2UNIX_DEPENDENCIES += gettext
-DOS2UNIX_MAKE_OPTS += LIBS_EXTRA=-lintl
-endif
-
 ifeq ($(BR2_USE_WCHAR),)
 DOS2UNIX_MAKE_OPTS += UCS=
 endif