Remove STAMP_DIR
authorArnout Vandecappelle <arnout@mind.be>
Mon, 17 Mar 2014 08:22:33 +0000 (09:22 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 17 Mar 2014 21:10:45 +0000 (22:10 +0100)
Since the migration of the toolchains to the generic package
infrastructure, it is no longer used.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile
docs/manual/how-buildroot-works.txt

index 2b1391740ad6090e20a9e50047322678d8c49340..011af57620644cafb6692045ad11b3a433298eaa 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -152,7 +152,6 @@ endif
 _BR2_GRAPH_OUT := $(or $(BR2_GRAPH_OUT),pdf)
 
 BUILD_DIR:=$(BASE_DIR)/build
-STAMP_DIR:=$(BASE_DIR)/stamps
 BINARIES_DIR:=$(BASE_DIR)/images
 TARGET_DIR:=$(BASE_DIR)/target
 # initial definition so that 'make clean' works for most users, even without
@@ -435,7 +434,7 @@ TARGETS_LEGAL_INFO:=$(patsubst %,%-legal-info,\
                $(TARGETS) $(TARGETS_HOST_DEPS) $(HOST_DEPS))))
 
 dirs: $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
-       $(HOST_DIR) $(BINARIES_DIR) $(STAMP_DIR)
+       $(HOST_DIR) $(BINARIES_DIR)
 
 $(BUILD_DIR)/buildroot-config/auto.conf: $(BR2_CONFIG)
        $(MAKE1) $(EXTRAMAKEARGS) HOSTCC="$(HOSTCC_NOCCACHE)" HOSTCXX="$(HOSTCXX_NOCCACHE)" silentoldconfig
@@ -454,7 +453,7 @@ world: target-post-image
        $(TARGETS) $(TARGETS_ROOTFS) \
        $(TARGETS_DIRCLEAN) $(TARGETS_SOURCE) $(TARGETS_LEGAL_INFO) \
        $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
-       $(HOST_DIR) $(BINARIES_DIR) $(STAMP_DIR)
+       $(HOST_DIR) $(BINARIES_DIR)
 
 ################################################################################
 #
@@ -462,7 +461,7 @@ world: target-post-image
 # dependencies anywhere else
 #
 ################################################################################
-$(BUILD_DIR) $(HOST_DIR) $(BINARIES_DIR) $(STAMP_DIR) $(LEGAL_INFO_DIR) $(REDIST_SOURCES_DIR_TARGET) $(REDIST_SOURCES_DIR_HOST):
+$(BUILD_DIR) $(HOST_DIR) $(BINARIES_DIR) $(LEGAL_INFO_DIR) $(REDIST_SOURCES_DIR_TARGET) $(REDIST_SOURCES_DIR_HOST):
        @mkdir -p $@
 
 # We make a symlink lib32->lib or lib64->lib as appropriate
@@ -824,7 +823,7 @@ printvars:
 
 clean:
        rm -rf $(TARGET_DIR) $(BINARIES_DIR) $(HOST_DIR) \
-               $(STAMP_DIR) $(BUILD_DIR) $(BASE_DIR)/staging \
+               $(BUILD_DIR) $(BASE_DIR)/staging \
                $(LEGAL_INFO_DIR)
 
 distclean: clean
index a96e45b0fe983a37b2b2106f79386f8b58bd0299..5ef6e0ff3628456bd9981a8168b5123bf7c6855f 100644 (file)
@@ -53,7 +53,7 @@ The main Makefile performs the following steps (once the
 configuration is done):
 
 * Create all the output directories: +staging+, +target+, +build+,
-  +stamps+, etc. in the output directory (+output/+ by default,
+  etc. in the output directory (+output/+ by default,
   another value can be specified using +O=+)
 
 * Generate the toolchain target. When an internal toolchain is used, this