gdbm: new package
authorFrancois Perrad <fperrad@gmail.com>
Fri, 19 Oct 2012 03:13:49 +0000 (03:13 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 3 Nov 2012 10:48:34 +0000 (11:48 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/gdbm/Config.in [new file with mode: 0644]
package/gdbm/gdbm.mk [new file with mode: 0644]

index 684ceec0513fdca962ab701611f87dc6489c5c17..a4f75c96eb56c2290c7a0d625b8feb5aa8cee073 100644 (file)
@@ -345,6 +345,7 @@ endmenu
 
 menu "Database"
 source "package/berkeleydb/Config.in"
+source "package/gdbm/Config.in"
 source "package/mysql_client/Config.in"
 source "package/sqlcipher/Config.in"
 source "package/sqlite/Config.in"
diff --git a/package/gdbm/Config.in b/package/gdbm/Config.in
new file mode 100644 (file)
index 0000000..d5aae83
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_GDBM
+       bool "gdbm"
+       help
+         GNU dbm is a set of database routines that use extensible hashing.
+         It works similar to the standard UNIX dbm routines.
+
+         http://www.gnu.org/software/gdbm/gdbm.html
+
diff --git a/package/gdbm/gdbm.mk b/package/gdbm/gdbm.mk
new file mode 100644 (file)
index 0000000..4971b12
--- /dev/null
@@ -0,0 +1,12 @@
+#############################################################
+#
+# gdbm
+#
+#############################################################
+GDBM_VERSION = 1.10
+GDBM_SITE = $(BR2_GNU_MIRROR)/gdbm
+GDBM_LICENSE = GPLv3
+GDBM_LICENSE_FILES = COPYING
+GDBM_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))