toolchain-external: update Arm ARM toolchain 8.2-2018.11
authorRomain Naour <romain.naour@gmail.com>
Wed, 2 Jan 2019 22:14:05 +0000 (23:14 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 4 Jan 2019 11:44:51 +0000 (12:44 +0100)
>From [1]:
* All GCC 8.2 features. For details on GCC 8 release series.
* Linaro specific pre-processor macros to ensure that this is a
  continuation from the Linaro releases.
* Spectre v1 mitigation backport from upstream FSF trunk include the
  revisions. This is an initial backport of those mitigations in
  the GNU toolchain and should be regarded as support for prototyping
  and early access only. Moreover, while the backports include support
  for the other architectures, they are included for completeness and
  all issues regarding these patches must be taken up upstream in the
  https://gcc.gnu.org/bugzilla by reproducing the same with upstream
  FSF trunk.
  Arm is interested in feedback regarding these workarounds for
  Spectre v1.
  A description of the mitigation has been published on LWN.net.

See "Release Note":
[1] https://developer.arm.com/open-source/gnu-toolchain/gnu-a/downloads#

Tested with qemu_arm_vexpress_defconfig.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
toolchain/toolchain-external/toolchain-external-arm-arm/Config.in
toolchain/toolchain-external/toolchain-external-arm-arm/toolchain-external-arm-arm.hash
toolchain/toolchain-external/toolchain-external-arm-arm/toolchain-external-arm-arm.mk

index 4ec61f2d07b0aff6f11c68e7879aa99c74073e12..044973788905acd3676623dd98310c00a7929107 100644 (file)
@@ -4,7 +4,7 @@ comment "Arm toolchains available for Cortex-A + EABIhf"
        depends on !BR2_STATIC_LIBS
 
 config BR2_TOOLCHAIN_EXTERNAL_ARM_ARM
-       bool "Arm ARM 2018.08"
+       bool "Arm ARM 2018.11"
        depends on BR2_arm
        depends on BR2_ARM_CPU_ARMV7A || BR2_ARM_CPU_ARMV8A
        depends on BR2_HOSTARCH = "x86_64"
@@ -14,7 +14,7 @@ config BR2_TOOLCHAIN_EXTERNAL_ARM_ARM
        select BR2_TOOLCHAIN_HAS_SSP
        select BR2_TOOLCHAIN_HAS_NATIVE_RPC
        select BR2_INSTALL_LIBSTDCPP
-       select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_18
+       select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_20
        select BR2_TOOLCHAIN_GCC_AT_LEAST_8
        select BR2_TOOLCHAIN_HAS_FORTRAN
        help
index f13c43a7efa714448f8074db6287e2bb67bdb325..cd7f5265475f9d110a07c4b90249db370792f40c 100644 (file)
@@ -1,4 +1,4 @@
-# From https://developer.arm.com/-/media/Files/downloads/gnu-a/8.2-2018.08/gcc-arm-8.2-2018.08-x86_64-arm-linux-gnueabihf.tar.xz.asc
-md5 dc7455746d90259337fb88c3e67f8855 gcc-arm-8.2-2018.08-x86_64-arm-linux-gnueabihf.tar.xz
+# From https://developer.arm.com/-/media/Files/downloads/gnu-a/8.2-2018.11/gcc-arm-8.2-2018.11-x86_64-arm-linux-gnueabihf.tar.xz.asc
+md5 59ccf965837ed1c5ba59e5ad4b688b21 gcc-arm-8.2-2018.11-x86_64-arm-linux-gnueabihf.tar.xz
 # locally calculated
-sha256 5b3f20e1327edc3073e545a5bd3d15f33e7f94181ff4e37a76e95924c1b439b9 gcc-arm-8.2-2018.08-x86_64-arm-linux-gnueabihf.tar.xz
+sha256 3f9bc7a68f744a5edc7caebff5f3f2c3bc1ff9d8ac8b05f7680a0071461deede gcc-arm-8.2-2018.11-x86_64-arm-linux-gnueabihf.tar.xz
index 03de21a28aa92e199dc5d2daf0d60208d7885226..0c21affd7bfb27862e21529bf9e6ccab4bb8be7a 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-TOOLCHAIN_EXTERNAL_ARM_ARM_VERSION = 2018.08
+TOOLCHAIN_EXTERNAL_ARM_ARM_VERSION = 2018.11
 TOOLCHAIN_EXTERNAL_ARM_ARM_SITE = https://developer.arm.com/-/media/Files/downloads/gnu-a/8.2-$(TOOLCHAIN_EXTERNAL_ARM_ARM_VERSION)
 
 TOOLCHAIN_EXTERNAL_ARM_ARM_SOURCE = gcc-arm-8.2-$(TOOLCHAIN_EXTERNAL_ARM_ARM_VERSION)-x86_64-arm-linux-gnueabihf.tar.xz