package/qemu: add option to enable virtual filesystem in host qemu
authorEtienne Carriere <etienne.carriere@linaro.org>
Thu, 22 Nov 2018 15:21:40 +0000 (16:21 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 24 Nov 2018 13:50:42 +0000 (14:50 +0100)
Signed-off-by: Etienne Carriere <etienne.carriere@linaro.org>
[Thomas: tweak option prompt]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qemu/Config.in.host
package/qemu/qemu.mk

index 957c7d2ae1e4a7cbc41dac8778efd9d983e5cfa3..f99f3e05cfecb21c6a8e6c2089699db22a2c0adf 100644 (file)
@@ -67,4 +67,10 @@ config BR2_PACKAGE_HOST_QEMU_VDE2
          Ethernet and can be used to create virtual switches to
          "plug" both physical and virtual machines in them.
 
+config BR2_PACKAGE_HOST_QEMU_VIRTFS
+       bool "Virtual filesystem support"
+       help
+         Enables support for virtual filesystem in Qemu allowing
+         shared filesystem between Qemu and its emulated target.
+
 endif
index 5bdf390bc982c600e684ebc7623ef6796cf889a8..5ee6abf7316d01b5cb7fcf7ae1475c40d3704ce1 100644 (file)
@@ -253,6 +253,10 @@ HOST_QEMU_OPTS += --enable-vde
 HOST_QEMU_DEPENDENCIES += host-vde2
 endif
 
+ifdef ($(BR2_PACKAGE_HOST_QEMU_VIRTFS),y)
+HOST_QEMU_OPTS += --enable-virtfs
+endif
+
 # Override CPP, as it expects to be able to call it like it'd
 # call the compiler.
 define HOST_QEMU_CONFIGURE_CMDS